diff mbox series

[bug#38852] gnu: python-py3status: Fix patch of file path

Message ID 20200101184349.ha7kwiyk6frqs6wy@zdrowyportier.kadziolka.net
State Accepted
Headers show
Series [bug#38852] gnu: python-py3status: Fix patch of file path | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Maja Kądziołka Jan. 1, 2020, 6:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-py3status): Fix patch of file
  path.
  [arguments]: Replace single-quotes with double-quotes so that the
  regex matches again. The "replace-with" value is not changed as it's
  not necessary and would introduce escaping noise.
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Jan. 6, 2020, 2:35 p.m. UTC | #1
Hello,

Jakub Kądziołka <kuba@kadziolka.net> skribis:

> * gnu/packages/python-xyz.scm (python-py3status): Fix patch of file
>   path.
>   [arguments]: Replace single-quotes with double-quotes so that the
>   regex matches again. The "replace-with" value is not changed as it's
>   not necessary and would introduce escaping noise.

Good catch.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b71982c3a..7001c69762 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9908,7 +9908,7 @@  to occurrences in strings and comments.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((file-path (assoc-ref inputs "file")))
                (substitute* "py3status/parse_config.py"
-                 (("\\['file', '-b'")
+                 (("\\[\"file\", \"-b\"")
                   (string-append "['" file-path "/bin/file', '-b'")))
                #t))))
        #:tests? #f)) ; TODO: Requires many libraries not in Guix.