diff mbox series

[bug#38845] gnu: libosinfo: Update to 1.7.1.

Message ID 20200101151312.30513-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#38845] gnu: libosinfo: Update to 1.7.1. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Christopher Baines Jan. 1, 2020, 3:13 p.m. UTC
* gnu/packages/virtualization.scm (libosinfo): Update to 1.7.1.
[source]: Switch the release tarball to xz compression.
[build-system]: Switch to the meson build system.
[arguments]: Switch the configure flags style to work with Meson.
---
 gnu/packages/virtualization.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

Comments

Ricardo Wurmus Jan. 1, 2020, 10:51 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/virtualization.scm (libosinfo): Update to 1.7.1.
> [source]: Switch the release tarball to xz compression.
> [build-system]: Switch to the meson build system.
> [arguments]: Switch the configure flags style to work with Meson.

LGTM!
Christopher Baines Jan. 2, 2020, 9:28 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/virtualization.scm (libosinfo): Update to 1.7.1.
>> [source]: Switch the release tarball to xz compression.
>> [build-system]: Switch to the meson build system.
>> [arguments]: Switch the configure flags style to work with Meson.
>
> LGTM!

Great, I've pushed this as 08e69c79dc729a5bc95e218d8e4569072b8a4a79 now.
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 33bfdade0f..51ba3c602a 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -87,6 +87,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -302,21 +303,21 @@  server and embedded PowerPC, and S390 guests.")
 (define-public libosinfo
   (package
     (name "libosinfo")
-    (version "1.5.0")
+    (version "1.7.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://releases.pagure.org/libosinfo/libosinfo-"
-                           version ".tar.gz"))
+                           version ".tar.xz"))
        (sha256
         (base32
-         "12b0xj9fz9q91d1pz9xm6aqap5k1ip0m9m3qvqmwjy1lk1kjasdz"))))
-    (build-system gnu-build-system)
+         "1s97sv24bybggjx6hgqba2qdqz3ivfpd4cmkh4zm5y59sim109mv"))))
+    (build-system meson-build-system)
     (arguments
      `(#:configure-flags
-       (list (string-append "--with-usb-ids-path="
+       (list (string-append "-Dwith-usb-ids-path="
                             (assoc-ref %build-inputs "usb.ids"))
-             (string-append "--with-pci-ids-path="
+             (string-append "-Dwith-pci-ids-path="
                             (assoc-ref %build-inputs "pci.ids")))))
     (inputs
      `(("libsoup" ,libsoup)