diff mbox series

[bug#38827] gnu: Add gitlab-runner.

Message ID 20191231091757.69869-1-r.majd@pantherx.org
State Work in progress
Headers show
Series [bug#38827] gnu: Add gitlab-runner. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Reza Alizadeh Majd Dec. 31, 2019, 9:17 a.m. UTC
* gnu/packages/ci.scm (gitlab-runner): New variable.
---
 gnu/packages/ci.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe Dec. 31, 2019, 11:06 a.m. UTC | #1
Hello!

> +;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>

You are a bit early :)

> +(define-public gitlab-runner
> +  (package
> +    (name "gitlab-runner")
> +    (version "12.6.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
> +                            version "/gitlab-runner-v" version ".tar.gz"))
> +        (sha256 (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))

Those lines are above the column limit.

> +    (build-system go-build-system)
> +    (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
> +    (home-page "https://docs.gitlab.com/runner/")
> +    (synopsis "GitLab Runner")
> +    (description "GitLab Runner is the open source project that is used
> +to run your jobs and send the results back to GitLab.")

No need to mention it is open source, otherwise, it wouldn't be
here. You could also elaborate a bit.

Could you send an updated version ?

Thanks,

Mathieu
Reza Alizadeh Majd Dec. 31, 2019, 1:21 p.m. UTC | #2
Hi, 

> 
> Those lines are above the column limit.
> 

I checked the package using `guix lint ...` but didn't receive any
warning about the column limit. 

> 
> No need to mention it is open source, otherwise, it wouldn't be
> here. You could also elaborate a bit.
> 

I use projects default document to fill the description field: 
https://docs.gitlab.com/runner/

do I need to update description to a custom one?
Mathieu Othacehe Dec. 31, 2019, 1:42 p.m. UTC | #3
> I checked the package using `guix lint ...` but didn't receive any
> warning about the column limit.

Yup, we would need to improve the linter :) This column limit rule  is
mentionned here[1].

> I use projects default document to fill the description field:
> https://docs.gitlab.com/runner/
>
> do I need to update description to a custom one?

Yes, sometimes the upstream description is too short, uses superlatives
or so. You'll find some guidelines here[2].

Thanks,

Mathieu

[1]: https://guix.gnu.org/manual/en/html_node/Formatting-Code.html#Formatting-Code
[2]: https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions
diff mbox series

Patch

diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index b49ac0f7c1..c9679c9674 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@ 
   #:use-module ((guix licenses) #:prefix l:)
   #:use-module (gnu packages)
   #:use-module (guix packages)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -44,7 +46,8 @@ 
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go))
 
 (define-public cuirass
   (let ((commit "e20ff86d97f7dd92dad140b5919e3cbdf2fb1ce6")
@@ -152,3 +155,21 @@ 
 intended as a replacement for Hydra.")
       (home-page "https://www.gnu.org/software/guix/")
       (license l:gpl3+))))
+
+(define-public gitlab-runner
+  (package
+    (name "gitlab-runner")
+    (version "12.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
+                            version "/gitlab-runner-v" version ".tar.gz"))
+        (sha256 (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
+    (home-page "https://docs.gitlab.com/runner/")
+    (synopsis "GitLab Runner")
+    (description "GitLab Runner is the open source project that is used
+to run your jobs and send the results back to GitLab.")
+    (license l:expat)))