diff mbox series

[bug#38820] gnu: arandr: Fix build.

Message ID 20191230174205.18101-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#38820] gnu: arandr: Fix build. | expand

Commit Message

Kei Kebreau Dec. 30, 2019, 5:42 p.m. UTC
This is a follow-up to commit 218c785850d5ecf3a7646d81ce90445419a5103b.

[arguments]: Remove unnecessary #:python flag.  Add 'wrap-gi-typelib' phase.
[inputs]: Remove python2-pygtk and add gtk+, python-pycairo, and
python-pygobject.
[native-inputs]: Replace python2-docutils with python-docutils.
---
 gnu/packages/xdisorg.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

Comments

Kei Kebreau Jan. 5, 2020, 4:23 p.m. UTC | #1
Since there have been no complaints and this is a minor change, I've
pushed it as commit 06c8e87224decebc0a3d5bdc7d2ca13cb2b08299 on master.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9b198a02da..ecf8973a82 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,20 +115,28 @@ 
                   #t))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2     ;incompatible with python 3
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'build 'configure
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "screenlayout/xrandr.py"
                (("\"xrandr\"") (string-append "\"" (assoc-ref inputs "xrandr")
                                               "/bin/xrandr\"")))
+             #t))
+         (add-after 'install 'wrap-gi-typelib
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out               (assoc-ref outputs "out"))
+                   (gi-typelib-path   (getenv "GI_TYPELIB_PATH")))
+               (wrap-program (string-append out "/bin/arandr")
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
              #t)))
        #:tests? #f)) ;no tests
-    (inputs `(("pygtk" ,python2-pygtk)
+    (inputs `(("gtk+" ,gtk+)
+              ("pycairo" ,python-pycairo)
+              ("pygobject" ,python-pygobject)
               ("xrandr" ,xrandr)))
     (native-inputs `(("gettext"           ,gettext-minimal)
-                     ("python-docutils"   ,python2-docutils)))
+                     ("python-docutils"   ,python-docutils)))
     (home-page "https://christian.amsuess.com/tools/arandr/")
     (synopsis "Another RandR graphical user interface")
     ;; TRANSLATORS: "X11 resize-and-rotate" should not be translated.