diff mbox series

[bug#38808] gnu: Add ghc-ghcid.

Message ID 20191230082614.13781-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#38808] gnu: Add ghc-ghcid. | expand

Commit Message

Alexandru-Sergiu Marton Dec. 30, 2019, 8:26 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-ghcid): New variable.
---
 gnu/packages/haskell-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

John Soo Jan. 3, 2020, 5:51 p.m. UTC | #1
Hi Alexandru-Sergiu,

I tested this out this morning. It looks pretty good to me.

Thanks a lot! I love seeing more haskell support in Guix.

John
John Soo Jan. 17, 2020, 3:57 p.m. UTC | #2
Hi Alexandru-Sergiu,

One thing to consider is maybe naming the package "ghcid" and putting
it in gnu/packages/haskell-apps.scm instead with the other haskell
executables.

John
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 716d14d7fb..a8710037ae 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4429,6 +4429,39 @@  properties for functions operating on them.")
 interfaces with ease.")
     (license license:bsd-3)))
 
+(define-public ghc-ghcid
+  (package
+    (name "ghc-ghcid")
+    (version "0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/ghcid/ghcid-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1vyjsxxp0jqqfkxp9r8by9qg794g0nj3k5zg7vlvh5v8xzigv8qg"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-extra" ,ghc-extra)
+       ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+       ("ghc-cmdargs" ,ghc-cmdargs)
+       ("ghc-fsnotify" ,ghc-fsnotify)
+       ("ghc-terminal-size" ,ghc-terminal-size)))
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+    (home-page
+     "https://github.com/ndmitchell/ghcid#readme")
+    (synopsis "GHCi based bare bones IDE")
+    (description
+     "Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\".
+A very simple Haskell development tool which shows you the errors in
+your project and updates them whenever you save.")
+    (license license:bsd-3)))
+
 (define-public ghc-gitrev
   (package
     (name "ghc-gitrev")