diff mbox series

[bug#38787] gnu: Add ghc-filepath-bytestring.

Message ID 20191229060905.769-1-kyle@kyleam.com
State Accepted
Headers show
Series [bug#38787] gnu: Add ghc-filepath-bytestring. | expand

Commit Message

Kyle Meyer Dec. 29, 2019, 6:09 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-filepath-bytestring): New variable.
---
The next release of git-annex (the current is 7.20191218) will depend on this
package.

 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 34085eabccb8a0ca280f8d1605fdf369a94dd88a

Comments

Efraim Flashner Dec. 29, 2019, 7:57 a.m. UTC | #1
Looks good. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fb6833207d..13e313820c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3998,6 +3998,30 @@  (define-public ghc-filemanip
 file contents, and more.")
     (license license:bsd-3)))
 
+(define-public ghc-filepath-bytestring
+  (package
+    (name "ghc-filepath-bytestring")
+    (version "1.4.2.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/filepath-bytestring/"
+             "filepath-bytestring-" version ".tar.gz"))
+       (sha256
+        (base32
+         "06shdskjj391hb9295slm9gg2rbn5fdq5v6fg0mgn3yl5dv8q5dx"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page "http://hackage.haskell.org/package/filepath-bytestring")
+    (synopsis "Library for manipulating RawFilePaths in a cross-platform way")
+    (description "This package provides a drop-in replacement for the standard
+@code{filepath} library, operating on @code{RawFilePath} values rather than
+@code{FilePath} values to get the speed benefits of using
+@code{ByteStrings}.")
+    (license license:bsd-3)))
+
 (define-public ghc-findbin
   (package
     (name "ghc-findbin")