diff mbox series

[bug#38711] build-system: qt: Actually use qt-build-system, not cmake-build-system.

Message ID 20191222214003.7352-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#38711] build-system: qt: Actually use qt-build-system, not cmake-build-system. | expand

Commit Message

Hartmut Goebel Dec. 22, 2019, 9:40 p.m. UTC
When the qt-build-system was created, based on the cmake-build-system,
some references to cmake have been missed to be changed.

* guix/build-system/qt.scm (qt-build, qt-cross-build)[modules]:
  Use qt-build-system, not cmake-build-system. [builder]: Call qt-build,
  not cmake-build.
---
 guix/build-system/qt.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Dec. 23, 2019, 1:30 p.m. UTC | #1
On Sun, Dec 22, 2019 at 10:40:03PM +0100, Hartmut Goebel wrote:
> When the qt-build-system was created, based on the cmake-build-system,
> some references to cmake have been missed to be changed.

This would explain some of the problems we've run into with, say,
mumble. If applying this means we can reverse
a7a91c01c98499c8a1e44fadea1b8f70e91fc16f and still have the binaries
wrapped then I say go for it.

> 
> * guix/build-system/qt.scm (qt-build, qt-cross-build)[modules]:
>   Use qt-build-system, not cmake-build-system. [builder]: Call qt-build,
>   not cmake-build.
> ---
>  guix/build-system/qt.scm | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/guix/build-system/qt.scm b/guix/build-system/qt.scm
> index b776845377..67fdfa1230 100644
> --- a/guix/build-system/qt.scm
> +++ b/guix/build-system/qt.scm
> @@ -126,14 +126,14 @@
>                        (qt-wrap-excluded-outputs ''())
>                        (system (%current-system))
>                        (imported-modules %qt-build-system-modules)
> -                      (modules '((guix build cmake-build-system)
> +                      (modules '((guix build qt-build-system)
>                                   (guix build utils))))
>    "Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
>  provides a 'CMakeLists.txt' file as its build system."
>    (define builder
>      `(begin
>         (use-modules ,@modules)
> -       (cmake-build #:source ,(match (assoc-ref inputs "source")
> +       (qt-build #:source ,(match (assoc-ref inputs "source")
Don't forget to re-indent the following lines
>                                  (((? derivation? source))
>                                   (derivation->output-path source))
>                                  ((source)
> @@ -208,7 +208,7 @@ provides a 'CMakeLists.txt' file as its build system."
>                              (system (%current-system))
>                              (build (nix-system->gnu-triplet system))
>                              (imported-modules %qt-build-system-modules)
> -                            (modules '((guix build cmake-build-system)
> +                            (modules '((guix build qt-build-system)
>                                         (guix build utils))))
>    "Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
>  with INPUTS.  This assumes that SOURCE provides a 'CMakeLists.txt' file as its
> @@ -237,7 +237,7 @@ build system."
>                       `(,name . ,path)))
>                    target-drvs))
>  
> -         (cmake-build #:source ,(match (assoc-ref native-drvs "source")
> +         (qt-build #:source ,(match (assoc-ref native-drvs "source")
And here too.
>                                    (((? derivation? source))
>                                     (derivation->output-path source))
>                                    ((source)
> -- 
> 2.21.1
>
Hartmut Goebel Dec. 23, 2019, 4:50 p.m. UTC | #2
Hi Efraim,

thanks for the review.


Am 23.12.19 um 14:30 schrieb Efraim Flashner:
> This would explain some of the problems we've run into with, say,
> mumble. If applying this means we can reverse
> a7a91c01c98499c8a1e44fadea1b8f70e91fc16f and still have the binaries
> wrapped then I say go for it.

Yes, this patch allows to revert
a7a91c01c98499c8a1e44fadea1b8f70e91fc16f. See also
<https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38553#47>.

I already reverted a7a91c01c and changed the other packages which used
the same pattern ((sddm, ktouch, kdeconnect, kdevelop))


> Don't forget to re-indent the following lines 

ACK. I did this in a separate commit to make the actual change more obvious.


Pushed as fce8ec9e151..50bdf0043.
Ludovic Courtès Dec. 23, 2019, 4:54 p.m. UTC | #3
Hi!

Efraim Flashner <efraim@flashner.co.il> skribis:

> On Sun, Dec 22, 2019 at 10:40:03PM +0100, Hartmut Goebel wrote:
>> When the qt-build-system was created, based on the cmake-build-system,
>> some references to cmake have been missed to be changed.

Oh, I see.

> This would explain some of the problems we've run into with, say,
> mumble. If applying this means we can reverse
> a7a91c01c98499c8a1e44fadea1b8f70e91fc16f and still have the binaries
> wrapped then I say go for it.

Agreed!

Ludo’.
diff mbox series

Patch

diff --git a/guix/build-system/qt.scm b/guix/build-system/qt.scm
index b776845377..67fdfa1230 100644
--- a/guix/build-system/qt.scm
+++ b/guix/build-system/qt.scm
@@ -126,14 +126,14 @@ 
                       (qt-wrap-excluded-outputs ''())
                       (system (%current-system))
                       (imported-modules %qt-build-system-modules)
-                      (modules '((guix build cmake-build-system)
+                      (modules '((guix build qt-build-system)
                                  (guix build utils))))
   "Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
 provides a 'CMakeLists.txt' file as its build system."
   (define builder
     `(begin
        (use-modules ,@modules)
-       (cmake-build #:source ,(match (assoc-ref inputs "source")
+       (qt-build #:source ,(match (assoc-ref inputs "source")
                                 (((? derivation? source))
                                  (derivation->output-path source))
                                 ((source)
@@ -208,7 +208,7 @@  provides a 'CMakeLists.txt' file as its build system."
                             (system (%current-system))
                             (build (nix-system->gnu-triplet system))
                             (imported-modules %qt-build-system-modules)
-                            (modules '((guix build cmake-build-system)
+                            (modules '((guix build qt-build-system)
                                        (guix build utils))))
   "Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
 with INPUTS.  This assumes that SOURCE provides a 'CMakeLists.txt' file as its
@@ -237,7 +237,7 @@  build system."
                      `(,name . ,path)))
                   target-drvs))
 
-         (cmake-build #:source ,(match (assoc-ref native-drvs "source")
+         (qt-build #:source ,(match (assoc-ref native-drvs "source")
                                   (((? derivation? source))
                                    (derivation->output-path source))
                                   ((source)