diff mbox series

[bug#38538] gnu: Add gnome-shell-extension-hide-app-icon

Message ID 20191219092254.GF917@E5400
State Accepted
Headers show
Series [bug#38538] gnu: Add gnome-shell-extension-hide-app-icon | expand

Commit Message

Efraim Flashner Dec. 19, 2019, 9:22 a.m. UTC
On Thu, Dec 19, 2019 at 11:20:04AM +0200, Efraim Flashner wrote:
> What does this need glib and glib:bin for? Is it just for building the
> schemas or does it actually need it at runtime?
> 

I also made some changes to the package
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 00ad701ad8..5aa2d292bf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -151,6 +151,52 @@  faster window switching.")
     (home-page "https://micheleg.github.io/dash-to-dock/")
     (license license:gpl2+)))
 
+(define-public gnome-shell-extension-hide-app-icon
+  (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
+        (revision "0"))
+    (package
+      (name "gnome-shell-extension-hide-app-icon")
+      (version (git-version "2.7" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
+                 (commit commit)))
+          (sha256
+           (base32
+            "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+          (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:tests? #f                ; no test target
+         #:make-flags (list (string-append "EXTENSIONS_DIR="
+                                           (assoc-ref %outputs "out")
+                                           "/share/gnome-shell/extensions"))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)      ; no configure script
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (copy-recursively "hide-app-icon@mrapp.sourceforge.com/"
+                                   (string-append out "/share/gnome-shell/extensions"))
+               #t))))))
+      (native-inputs
+       `(("intltool" ,intltool)))
+      (propagated-inputs
+       `(("glib" ,glib)
+         ("glib" ,glib "bin")))
+      (synopsis "Hide app icon from GNOME's panel")
+      (description "This extension allows to hide the icon and/or title of the
+currently focused application in the top panel of the GNOME shell.")
+      (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+      (license
+       ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+       ;; latter v2.  No mention of "or later" in either place or in the code.
+       (list license:gpl2
+             license:gpl3)))))
+
 (define-public gnome-shell-extension-noannoyance
   (package
     (name "gnome-shell-extension-noannoyance")