diff mbox series

[bug#38590] gnu: emacs-telega: Don't propagate ffmpeg.

Message ID 20191213130524.14180-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#38590] gnu: emacs-telega: Don't propagate ffmpeg. | expand

Commit Message

Leo Prikler Dec. 13, 2019, 1:05 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-telega) [phases]:
<telega-data-patch>: Rename to telega-paths-patch.
<telega-paths-patch>: Substitute ffplay path.
[propagated-inputs] <ffmpeg>: Move from here ...
[inputs] <ffmpeg>: ... to here.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)

Comments

Brett Gilio Dec. 13, 2019, 2:29 p.m. UTC | #1
Good changes, Leo. I will push these ASAP.

Dec 13, 2019 7:09:37 AM Leo Prikler <leo.prikler@student.tugraz.at>:

> * gnu/packages/emacs-xyz.scm (emacs-telega) [phases]:
> <telega-data-patch>: Rename to telega-paths-patch.
> <telega-paths-patch>: Substitute ffplay path.
> [propagated-inputs] <ffmpeg>: Move from here ...
> [inputs] <ffmpeg>: ... to here.
> ---
> gnu/packages/emacs-xyz.scm | 20 ++++++++++++++------
> 1 file changed, 14 insertions(+), 6 deletions(-)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ae7e7a64cc..bc36b5dbce 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -20113,10 +20113,18 @@ fish-completion. It can be used in both Eshell and M-x shell.")
> (("python3 run_tests.py")
> ""))
> #t))
> - ;; Modify telega-util to reflect unique dir name in
> - ;; `telega-install-data' phase.
> - (add-after 'unpack 'telega-data-patch
> - (lambda _
> + (add-after 'unpack 'telega-paths-patch
> + (lambda* (#:key inputs #:allow-other-keys)
> + ;; Hardcode `ffplay path.
> + (let ((ffplay-bin (string-append (assoc-ref inputs "ffmpeg")
> + "/bin/ffplay")))
> + (substitute* "telega-ffplay.el"
> + (("\\(executable-find \"ffplay\"\\)")
> + (string-append
> + "(and (file-executable-p \"" ffplay-bin "\")"
> + "\"" ffplay-bin "\")"))))
> + ;; Modify telega-util to reflect unique dir name in
> + ;; `telega-install-data' phase.
> (substitute* "telega-util.el"
> (("\\(concat \"etc/\" filename\\) telega--lib-directory")
> "(concat \"telega-data/\" filename)
> @@ -20149,7 +20157,6 @@ fish-completion. It can be used in both Eshell and M-x shell.")
> (invoke "python3" "server/run_tests.py")
> #t))
> (delete 'configure)
> -
> ;; Build emacs-side using `emacs-build-system'
> (add-after 'compress-documentation 'emacs-add-source-to-load-path
> (assoc-ref emacs:%standard-phases 'add-source-to-load-path))
> @@ -20168,9 +20175,10 @@ fish-completion. It can be used in both Eshell and M-x shell.")
> (assoc-ref emacs:%standard-phases 'build))
> (add-after 'emacs-build 'emacs-make-autoloads
> (assoc-ref emacs:%standard-phases 'make-autoloads)))))
> + (inputs
> + `(("ffmpeg" ,ffmpeg))) ; mp4/gif support.
> (propagated-inputs
> `(("emacs-visual-fill-column" ,emacs-visual-fill-column)
> - ("ffmpeg" ,ffmpeg) ; mp4/gif support.
> ("libwebp" ,libwebp))) ; sticker support.
> (native-inputs
> `(("tdlib" ,tdlib)
> -- 
> 2.24.1
>
Brett Gilio Dec. 13, 2019, 6:07 p.m. UTC | #2
Pushed with 5f12df7ea6dd8422aaf5b27f07b27897073a65bd.

I made some very small revisions.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae7e7a64cc..bc36b5dbce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20113,10 +20113,18 @@  fish-completion.  It can be used in both Eshell and M-x shell.")
                  (("python3 run_tests.py")
                   ""))
                #t))
-           ;; Modify telega-util to reflect unique dir name in
-           ;; `telega-install-data' phase.
-           (add-after 'unpack 'telega-data-patch
-             (lambda _
+           (add-after 'unpack 'telega-paths-patch
+             (lambda* (#:key inputs #:allow-other-keys)
+               ;; Hardcode `ffplay path.
+               (let ((ffplay-bin (string-append (assoc-ref inputs "ffmpeg")
+                                                "/bin/ffplay")))
+                 (substitute* "telega-ffplay.el"
+                   (("\\(executable-find \"ffplay\"\\)")
+                    (string-append
+                     "(and (file-executable-p \"" ffplay-bin "\")"
+                     "\"" ffplay-bin "\")"))))
+               ;; Modify telega-util to reflect unique dir name in
+               ;; `telega-install-data' phase.
                (substitute* "telega-util.el"
                  (("\\(concat \"etc/\" filename\\) telega--lib-directory")
                   "(concat \"telega-data/\" filename)
@@ -20149,7 +20157,6 @@  fish-completion.  It can be used in both Eshell and M-x shell.")
                (invoke "python3" "server/run_tests.py")
                #t))
            (delete 'configure)
-           
            ;; Build emacs-side using `emacs-build-system'
            (add-after 'compress-documentation 'emacs-add-source-to-load-path
              (assoc-ref emacs:%standard-phases 'add-source-to-load-path))
@@ -20168,9 +20175,10 @@  fish-completion.  It can be used in both Eshell and M-x shell.")
              (assoc-ref emacs:%standard-phases 'build))
            (add-after 'emacs-build 'emacs-make-autoloads
              (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+      (inputs
+       `(("ffmpeg" ,ffmpeg))) ; mp4/gif support.
       (propagated-inputs
        `(("emacs-visual-fill-column" ,emacs-visual-fill-column)
-         ("ffmpeg" ,ffmpeg) ; mp4/gif support.
          ("libwebp" ,libwebp))) ; sticker support.
       (native-inputs
        `(("tdlib" ,tdlib)