diff mbox series

[bug#38584] gnu: Add papirus-icon-theme.

Message ID 20191212222135.9879-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#38584] gnu: Add papirus-icon-theme. | expand

Commit Message

Giacomo Leidi Dec. 12, 2019, 10:21 p.m. UTC
* gnu/packages/gnome-xyz.scm (papirus-icon-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ludovic Courtès Dec. 15, 2019, 9:54 p.m. UTC | #1
Hi,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/packages/gnome-xyz.scm (papirus-icon-theme): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d05bdf0ac0..00ad701ad8 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -213,3 +213,37 @@  It uses ES6 syntax and claims to be more actively maintained than others.")
 dark elements.  It supports GNOME, Unity, Xfce, and Openbox.")
     (home-page "https://numixproject.github.io")
     (license license:gpl3+)))
+
+(define-public papirus-icon-theme
+  (let ((version "0.0.0") ;; The package does not use semver
+        (revision "0")
+        (tag "20191201"))
+    (package
+      (name "papirus-icon-theme")
+      (version (git-version version revision tag))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
+               (commit tag)))
+         (sha256
+          (base32
+           "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'bootstrap)
+         (delete 'configure)
+         (delete 'build))))
+      (native-inputs
+       `(("gtk+:bin" ,gtk+ "bin")))
+      (home-page "https://git.io/papirus-icon-theme")
+      (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
+      (description "Papirus is a fork of the icon theme Paper with a lot of new icons
+and a few extra features.")
+      (license license:gpl3))))