diff mbox series

[bug#38553,07/12] gnu: Add kronometer.

Message ID 20191209215358.24449-7-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add two KDE packages and 10 KDE utils | expand

Commit Message

Hartmut Goebel Dec. 9, 2019, 9:53 p.m. UTC
* gnu/packages/kde-utils.scm (kronometer): New variable.
---
 gnu/packages/kde-utils.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index ed2312e48f..927bfc2351 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -202,3 +202,45 @@  also has support for user defined phrasebooks.
 It includes a history of spoken sentences from which the user can select
 sentences to be re-spoken.")
     (license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kronometer
+  (package
+    (name "kronometer")
+    (version "2.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/kronometer/" version
+                           "/src/kronometer-" version ".tar.xz"))
+       (sha256
+        (base32 "05hs8729a3aqjpwmn2xdf2sriacrll4sj4ax3lm4s1ravj09n9bm"))))
+    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kauth" ,kauth)
+       ("kconfig" ,kconfig)
+       ("kconfigwidgets", kconfigwidgets)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kcrash" ,kcrash)
+       ("ki18n" ,ki18n)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kxmlgui" ,kxmlgui)
+       ("oxygen-icons" ,oxygen-icons) ;; default icon set
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases (@ (guix build qt-build-system) %standard-phases)
+         (add-before 'check 'check-setup
+           (lambda _
+             ;; make Qt render "offscreen", required for tests
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (home-page "https://kde.org/applications/utilities/org.kde.kronometer")
+    (synopsis "Simple stopwatch application")
+    (description "Kronometer is a stopwatch application.  It features the
+basic stopwatch actions (pause, resume, reset, laps), as well as the ability
+to save the times and resume them later.")
+    (license license:gpl2+)))