diff mbox series

[bug#38553,06/12] gnu: Add kmouth.

Message ID 20191209215358.24449-6-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add two KDE packages and 10 KDE utils | expand

Commit Message

Hartmut Goebel Dec. 9, 2019, 9:53 p.m. UTC
* gnu/packages/kde-utils.scm (kmouth): New variable.
---
 gnu/packages/kde-utils.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 907efc52d9..ed2312e48f 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -162,3 +162,43 @@  disabled")
 briefly.  It was designed to help those with repetitive strain injuries, for
 whom pressing buttons hurts.")
     (license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kmouth
+  (package
+    (name "kmouth")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kmouth-" version ".tar.xz"))
+       (sha256
+        (base32 "1agjxf1jfi967hj1iz788n6cna6fr7qg80zsx6s119hg7b0xwqmr"))))
+    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kcompletion" ,kcompletion)
+       ("kconfig", kconfig)
+       ("kconfigwidgets", kconfigwidgets)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kcrash" ,kcrash)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kxmlgui" ,kxmlgui)
+       ("oxygen-icons" ,oxygen-icons) ;; default icon set
+       ("qtbase" ,qtbase)
+       ("qtspeech" ,qtspeech)))
+    (home-page "https://kde.org/applications/utilities/org.kde.kmouth")
+    (synopsis "Type-and-say frontend for speech synthesizers")
+    (description "KMouth is a program which enables persons that cannot speak
+to let their computer speak, e.g. mutal people or people who have lost their
+voice.  It has a text input field and speaks the sentences that you enter.  It
+also has support for user defined phrasebooks.
+
+It includes a history of spoken sentences from which the user can select
+sentences to be re-spoken.")
+    (license (list license:gpl2+ license:fdl1.2+))))