diff mbox series

[bug#38553,02/12] gnu: Add zeroconf-ioslave.

Message ID 20191209215358.24449-2-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add two KDE packages and 10 KDE utils | expand

Commit Message

Hartmut Goebel Dec. 9, 2019, 9:53 p.m. UTC
* gnu/packages/kde.scm (zeroconf-ioslave): New variable.
---
 gnu/packages/kde.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 33bcaaefd2..d1715fed68 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -691,3 +691,31 @@  system-wide profiler for Linux using statistical sampling with hardware
 performance counters.  There also exist converters for profiling output of
 Python, PHP, and Perl.")
     (license license:gpl2)))
+
+(define-public zeroconf-ioslave
+  (package
+    (name "zeroconf-ioslave")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/zeroconf-ioslave-" version ".tar.xz"))
+       (sha256
+        (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
+    (properties `((tags . ("Desktop" "KDE" "Network"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kdbusaddons" ,kdbusaddons)
+       ("kdnssd" ,kdnssd)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)))
+    (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
+    (synopsis "DNS-SD Service Discovery Monitor")
+    (description "Adds an entry to Dolphin's Network page to show local
+services such as printers which advertise themselves with DNSSD (called Avahi
+or Bonjour by other projects).")
+    (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))