diff mbox series

[bug#38548] gnu: Add love-nuklear.

Message ID 20191209093259.16706-1-jethrocao@gmail.com
State Accepted
Headers show
Series [bug#38548] gnu: Add love-nuklear. | expand

Commit Message

Jethro Cao Dec. 9, 2019, 9:32 a.m. UTC
* gnu/packages/game-development.scm (love-nuklear): New variable.
---
 gnu/packages/game-development.scm | 32 +++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 833f00b77c..f47e580c27 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -653,6 +653,38 @@  programming language.")
     (home-page "https://love2d.org/")
     (license license:zlib)))
 
+(define-public love-nuklear
+ (let ((version "v2.6")
+       (commit "fef4e00a602efb16c57ae962850b6e7a01f7a29a"))
+  (package
+   (name "love-nuklear")
+   (version (git-version version "+4commits" commit))
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/keharriso/love-nuklear/")
+                  (commit commit)
+                  (recursive? #t) 
+                  ;; NOTE: the Nuklear submodule's HEAD is at commit "adc52d7" of Oct 1 2019
+                  ;; TODO: package Nuklear, and explicitly specify it as a native (build) input
+                  ))
+            (file-name (git-file-name name version))
+            (sha256 
+             (base32 
+              "15qmy8mfwkxy2x9rmxs6f9cyvjvwwj6yf78bs863xmc56dmjzzbn"))))
+   (build-system cmake-build-system)
+   (arguments
+    `(#:build-type "Release"
+      #:tests? #f))
+   (inputs
+    `(("luajit" ,luajit)))
+   (synopsis "Lightweight immediate mode GUI for LÖVE games")
+   (description "LÖVE is a Lua framework for making 2D games. Nuklear
+is a minimal state immediate mode graphical user interface toolkit. This
+package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
+   (home-page "https://github.com/keharriso/love-nuklear/")
+   (license license:expat))))
+
 (define-public allegro-4
   (package
     (name "allegro")