diff mbox series

[bug#38538] gnu: Add gnome-shell-extension-hide-app-icon

Message ID 20191208201249.5479-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#38538] gnu: Add gnome-shell-extension-hide-app-icon | expand

Commit Message

Leo Prikler Dec. 8, 2019, 8:12 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon):
New variable.
---
 gnu/packages/gnome-xyz.scm | 47 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

Comments

Efraim Flashner Dec. 19, 2019, 9:20 a.m. UTC | #1
What does this need glib and glib:bin for? Is it just for building the
schemas or does it actually need it at runtime?
Leo Prikler Dec. 19, 2019, 11 a.m. UTC | #2
Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim Flashner:
> What does this need glib and glib:bin for? Is it just for building
> the
> schemas or does it actually need it at runtime?
To be honest, I'm not quite sure.  I've copied this part from my dash-
to-dock extension, wherein I copied it from the gnome-shell-extensions
package.

As far as I'm aware both packages do build schemas, but I'm not sure
how extensions handle them at runtime.  Perhaps this is already wrong
in the package I originally copied the snippet from.  I'll try to see
how far I can get with depropagation.

Regards,
Leo
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 7c3fb072c0..80870fd25d 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -26,6 +26,7 @@ 
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
@@ -149,6 +150,52 @@  faster window switching.")
     (home-page "https://micheleg.github.io/dash-to-dock/")
     (license license:gpl2+)))
 
+(define-public gnome-shell-extension-hide-app-icon
+  (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
+        (revision "0"))
+    (package
+      (name "gnome-shell-extension-hide-app-icon")
+      (version (git-version "2.7" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:tests? #f
+         #:make-flags (list (string-append "EXTENSIONS_DIR="
+                                           (assoc-ref %outputs "out")
+                                           "/share/gnome-shell/extensions"))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'bootstrap)
+           (delete 'configure)
+           (add-before 'install 'prepare-install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (mkdir-p (string-append (assoc-ref outputs "out")
+                                       "/share/gnome-shell/extensions")))))))
+      (native-inputs
+       `(("intltool" ,intltool)
+         ("unzip" ,unzip)
+         ("zip" ,zip)))
+      (propagated-inputs
+       `(("glib" ,glib)
+         ("glib" ,glib "bin")))
+      (synopsis "Hide app icon from GNOME's panel")
+      (description "This extension allows to hide the icon and/or title of the
+currently focused application in the top panel of the GNOME shell.")
+      (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+      (license
+       ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+       ;; latter v2.  No mention of "or later" in either place or in the code.
+       (list license:gpl2
+             license:gpl3)))))
+
 (define-public gnome-shell-extension-noannoyance
   (package
     (name "gnome-shell-extension-noannoyance")