diff mbox series

[bug#38532,02/11] gnu: Add dragon.

Message ID 20191208164355.7374-2-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add audiofile and KDE mulitmedia applications. | expand

Commit Message

Hartmut Goebel Dec. 8, 2019, 4:43 p.m. UTC
* gnu/packages/kde-multimedia.scm: New file.
* gnu/lokal.mk (MODULES): Add it.
---
 gnu/local.mk                    |  1 +
 gnu/packages/kde-multimedia.scm | 73 +++++++++++++++++++++++++++++++++
 2 files changed, 74 insertions(+)
 create mode 100644 gnu/packages/kde-multimedia.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 91afc8f059..ecff13b540 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -279,6 +279,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/kawa.scm				\
   %D%/packages/kde.scm				\
   %D%/packages/kde-frameworks.scm		\
+  %D%/packages/kde-multimedia.scm		\
   %D%/packages/kde-plasma.scm			\
   %D%/packages/kerberos.scm			\
   %D%/packages/key-mon.scm			\
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
new file mode 100644
index 0000000000..e828f97e6e
--- /dev/null
+++ b/gnu/packages/kde-multimedia.scm
@@ -0,0 +1,73 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-multimedia)
+  #:use-module (guix build-system qt)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages qt))
+
+(define-public dragon
+  (package
+    (name "dragon")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/dragon-" version ".tar.xz"))
+       (sha256
+        (base32 "02l16k4sgrxbczxp8rlnxbylb5fmjh4zhl4xw55qxkvmvxnjy5zr"))))
+    (properties `((tags . ("Desktop" "KDE" "Multimedia"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kconfig" ,kconfig)
+       ("kconfigwidgets" ,kconfigwidgets)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kcrash" ,kcrash)
+       ("kdbusaddons" ,kdbusaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("kjobwidgets" ,kjobwidgets)
+       ("knotifications" ,knotifications)
+       ("kparts" ,kparts)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kwindowsystem" ,kwindowsystem)
+       ("kxmlgui" ,kxmlgui)
+       ("oxygen-icons" ,oxygen-icons) ; default icon set
+       ("phonon" ,phonon)
+       ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
+       ("qtbase" ,qtbase)
+       ("solid" ,solid)))
+    (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
+    (synopsis "Simple video player")
+    (description "Dragon Player is a multimedia player where the focus is on
+simplicity, instead of features.  Dragon Player does one thing, and only one
+thing, which is playing multimedia files.  It's simple interface is designed
+not to get in your way and instead empower you to simply play multimedia
+files.
+
+This package is part of the KDE multimedia module.")
+    (license (list license:gpl2+ license:fdl1.2+))))