diff mbox series

[bug#38532,11/11] gnu: Add kamoso.

Message ID 20191208164355.7374-11-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add audiofile and KDE mulitmedia applications. | expand

Commit Message

Hartmut Goebel Dec. 8, 2019, 4:43 p.m. UTC
* gnu/packages/kde-multimedia.scm (kamoso): New variable.
---
 gnu/packages/kde-multimedia.scm | 49 +++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index ffdda58d83..ba262a0599 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -29,6 +29,7 @@ 
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages linux)
@@ -551,3 +552,51 @@  using Baloo.  The private one can be configured to scan music on chosen paths.
 The Baloo one is much faster because Baloo is providing all needed data from
 its own database.  You can build and play your own playlist.")
     (license license:lgpl3+)))
+
+(define-public kamoso
+  (package
+    (name "kamoso")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kamoso-" version ".tar.xz"))
+       (sha256
+        (base32 "0j0lr2gwaxwchgfp54dashm1b39gsaw4ly9p8ybavwwzhjkdqza3"))))
+    (properties `((tags . ("Desktop" "KDE" "Multimedia"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("glib:bin" ,glib "bin")
+       ("kdoctools" ,kdoctools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("kconfig" ,kconfig)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("kirigami" ,kirigami)
+       ("knotifications" ,knotifications)
+       ("kparts" ,kparts)
+       ("oxygen-icons" ,oxygen-icons) ; default icon set
+       ("purpose" ,purpose)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtquickcontrols" ,qtquickcontrols)
+       ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
+       ("qtx11extras" ,qtx11extras)))
+    (arguments
+     `(#:tests? #f ; test program gets built, but is not found
+       #:configure-flags
+       (list "-DBUILD_TESTING=OFF" ; not run anyway, see above
+             (string-append "-DCMAKE_CXX_FLAGS=-I"
+                            (assoc-ref %build-inputs "gst-plugins-base")
+                            "/include/gstreamer-1.0"))))
+    (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
+    (synopsis "Take pictures and videos out of your webcam")
+    (description "Kamoso is a simple and friendly program to use your
+camera.  Use it to take pictures and make videos to share.")
+    (license (list license:gpl2+ license:lgpl2.0+))))