diff mbox series

[bug#38527] gnu: libdbi-drivers: Fix build with multi-output mariadb.

Message ID 20191208125053.17828-1-glv@posteo.net
State Accepted
Headers show
Series [bug#38527] gnu: libdbi-drivers: Fix build with multi-output mariadb. | expand

Commit Message

Guillaume Le Vaillant Dec. 8, 2019, 12:50 p.m. UTC
* gnu/packages/databases.scm (libdbi-drivers)[native-inputs]: Add mysql and
  mysql-dev.
  [inputs]: Remove mysql and add mysql-lib and zlib.
  [arguments]: Remove unnecessary configure-flags and disable mysql
  test because mysql_install_db fails to run.
---
 gnu/packages/databases.scm | 28 ++++++++++++++--------------
 1 file changed, 14 insertions(+), 14 deletions(-)

Comments

Marius Bakke Dec. 18, 2019, 9:49 p.m. UTC | #1
Guillaume Le Vaillant <glv@posteo.net> writes:

> * gnu/packages/databases.scm (libdbi-drivers)[native-inputs]: Add mysql and
>   mysql-dev.
>   [inputs]: Remove mysql and add mysql-lib and zlib.
>   [arguments]: Remove unnecessary configure-flags and disable mysql
>   test because mysql_install_db fails to run.

Whoops, I did not see this issue until I had fixed it and searched for a
recent bug report on help-guix@.  So I ended up pushing a variant that
fixed the MariaDB problem in 9077cf68ec57c0303ef7746e203c3fe5ed041add.

By the way, could you create an account on Savannah so that we can grant
you commit access?  If you are okay with that, please send a signed
reply to this message signed by the same GPG key that you uploaded to
Savannah for signing git commits.

Thanks,
Marius
Marius Bakke Dec. 26, 2019, 4:57 p.m. UTC | #2
Guillaume Le Vaillant <glv@posteo.net> writes:

> Marius Bakke skribis:
>
>> Guillaume Le Vaillant <glv@posteo.net> writes:
>>
>>> * gnu/packages/databases.scm (libdbi-drivers)[native-inputs]: Add mysql and
>>>   mysql-dev.
>>>   [inputs]: Remove mysql and add mysql-lib and zlib.
>>>   [arguments]: Remove unnecessary configure-flags and disable mysql
>>>   test because mysql_install_db fails to run.
>>
>> Whoops, I did not see this issue until I had fixed it and searched for a
>> recent bug report on help-guix@.  So I ended up pushing a variant that
>> fixed the MariaDB problem in 9077cf68ec57c0303ef7746e203c3fe5ed041add.
>>
>> By the way, could you create an account on Savannah so that we can grant
>> you commit access?  If you are okay with that, please send a signed
>> reply to this message signed by the same GPG key that you uploaded to
>> Savannah for signing git commits.
>>
>> Thanks,
>> Marius
>
> Hi, I created an account on Savannah (account name is "glv"). The GPG
> key I usually use is an ED25519 key, but it looks like the version of
> GnuPG on Savannah is old and doesn't support that. So I added a DSA
> subkey and tried to upload the updated key. The Savannah website printed
> a "key saved" message, but I'm not sure if it will work as the main key
> is an ED25519 one...

Looks good!

I have added you to the project now, so you should be able to push
commits directly.

Make sure to read HACKING, as well as the "Contributing" section of the
manual; and don't be afraid to ask on #guix or the lists if you are
unsure about anything.

Thank you, and welcome!
Guillaume Le Vaillant Dec. 27, 2019, 10:34 a.m. UTC | #3
Marius Bakke skribis:

> Guillaume Le Vaillant <glv@posteo.net> writes:
>
>> Marius Bakke skribis:
>>
>>> Guillaume Le Vaillant <glv@posteo.net> writes:
>>>
>>>> * gnu/packages/databases.scm (libdbi-drivers)[native-inputs]: Add mysql and
>>>>   mysql-dev.
>>>>   [inputs]: Remove mysql and add mysql-lib and zlib.
>>>>   [arguments]: Remove unnecessary configure-flags and disable mysql
>>>>   test because mysql_install_db fails to run.
>>>
>>> Whoops, I did not see this issue until I had fixed it and searched for a
>>> recent bug report on help-guix@.  So I ended up pushing a variant that
>>> fixed the MariaDB problem in 9077cf68ec57c0303ef7746e203c3fe5ed041add.
>>>
>>> By the way, could you create an account on Savannah so that we can grant
>>> you commit access?  If you are okay with that, please send a signed
>>> reply to this message signed by the same GPG key that you uploaded to
>>> Savannah for signing git commits.
>>>
>>> Thanks,
>>> Marius
>>
>> Hi, I created an account on Savannah (account name is "glv"). The GPG
>> key I usually use is an ED25519 key, but it looks like the version of
>> GnuPG on Savannah is old and doesn't support that. So I added a DSA
>> subkey and tried to upload the updated key. The Savannah website printed
>> a "key saved" message, but I'm not sure if it will work as the main key
>> is an ED25519 one...
>
> Looks good!
>
> I have added you to the project now, so you should be able to push
> commits directly.
>
> Make sure to read HACKING, as well as the "Contributing" section of the
> manual; and don't be afraid to ask on #guix or the lists if you are
> unsure about anything.
>
> Thank you, and welcome!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cb843672af..377efed42b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3234,35 +3234,35 @@  simultaneous database connections by using this framework.")
     (build-system gnu-build-system)
     (native-inputs
      `(("inetutils" ,inetutils)
-       ("glibc-locales" ,glibc-locales)))
+       ("glibc-locales" ,glibc-locales)
+       ("mysql" ,mariadb)
+       ("mysql-dev" ,mariadb "dev")))
     (inputs
      `(("libdbi" ,libdbi)
-       ("mysql" ,mariadb)
+       ("mysql-lib" ,mariadb "lib")
        ("postgresql" ,postgresql)
-       ("sqlite" ,sqlite)))
+       ("sqlite" ,sqlite)
+       ("zlib" ,zlib)))
     (arguments
      `(#:configure-flags
-       (let ((libdbi (assoc-ref %build-inputs "libdbi"))
-             (mysql (assoc-ref %build-inputs "mysql"))
-             (postgresql (assoc-ref %build-inputs "postgresql"))
-             (sqlite (assoc-ref %build-inputs "sqlite")))
+       (let ((libdbi (assoc-ref %build-inputs "libdbi")))
          (list "--disable-docs"
                (string-append "--with-dbi-incdir=" libdbi "/include")
                (string-append "--with-dbi-libdir=" libdbi "/lib")
                "--with-mysql"
-               (string-append "--with-mysql-incdir=" mysql "/include/mysql")
-               (string-append "--with-mysql-libdir=" mysql "/lib")
                "--with-pgsql"
-               (string-append "--with-pgsql-incdir=" postgresql "/include")
-               (string-append "--with-pgsql-libdir=" postgresql "/lib")
-               "--with-sqlite3"
-               (string-append "--with-sqlite-incdir=" sqlite "/include")
-               (string-append "--with-sqlite-libdir=" sqlite "/lib")))
+               "--with-sqlite3"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-tests
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "tests/test_mysql.sh"
+               (("^mysql_install_db.*")
+                ;; FIXME: Disable the mysql test for now.
+                ;; The mysql_install_db program needs files in both the
+                ;; mariadb and mariadb:lib packages and fails to find
+                ;; the ones in mariadb:lib.
+                "exit 0\n")
                (("^MYMYSQLD=.*")
                 (string-append "MYMYSQLD="
                                (assoc-ref inputs "mysql")