diff mbox series

[bug#38508] gnu: libraft: Update to 0.9.11 (from 0.9.5)

Message ID 20191206083652.22399-1-andrew@interpretmath.pw
State Accepted
Headers show
Series [bug#38508] gnu: libraft: Update to 0.9.11 (from 0.9.5) | expand

Commit Message

Andrew Miloradovsky Dec. 6, 2019, 8:36 a.m. UTC
* gnu/packages/cluster.scm (libraft)[arguments]: enable libuv I/O backend
---
 gnu/packages/cluster.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Efraim Flashner Dec. 11, 2019, 2:49 a.m. UTC | #1
Patch pushed. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 9548352d12..4e16473fa4 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -87,7 +87,7 @@  independently or together to provide resilient infrastructures.")
 (define-public libraft
   (package
     (name "libraft")
-    (version "0.9.5")
+    (version "0.9.11")
     (home-page "https://github.com/canonical/raft")
     (source (origin
               (method git-fetch)
@@ -96,10 +96,12 @@  independently or together to provide resilient infrastructures.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1q49f5mmv6nr6dxhnp044xwc6jlczgh0nj0bl6718wiqh28411x0"))))
-    (arguments '(#:configure-flags '("--disable-uv")))
-    ;; The uv plugin tests fail, if libuv (or the example) is enabled,
-    ;; because setting up the environment requires too much privileges.
+                "00rsq4z9nykmf7r5rlpv1y6bvckcmg3zv57vh1h681y5pij6cch1"))))
+    (arguments '(#:configure-flags '("--enable-uv")
+                 #:tests? #f))
+    ;; The uv plugin tests fail, if libuv (or the example) is enabled.
+    (inputs
+     `(("libuv" ,libuv)))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)