diff mbox series

[bug#38385,v3,1/2] gnu: Add vde2.

Message ID 20191204160205.11011-2-dnbarbato@posteo.de
State Accepted
Headers show
Series gnu: qemu: Build with vde2 support. | expand

Commit Message

Diego Nicola Barbato Dec. 4, 2019, 4:02 p.m. UTC
* gnu/packages/networking.scm (vde2): New variable.
---
 gnu/packages/networking.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ludovic Courtès Dec. 11, 2019, 11:02 a.m. UTC | #1
Hi,

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

> * gnu/packages/networking.scm (vde2): New variable.

[...]

> * gnu/packages/virtualization.scm (qemu)[inputs]: Add vde2.
> * gnu/packages/virtualization.scm (qemu-minimal)[inputs]: Remove vde2 from
>   inherited inputs.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 05f348ad0f..0a9545c56d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
 ;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
+;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2822,3 +2823,33 @@  to be a teaching tool and presents the subnetting results as
 easy-to-understand binary values.")
     (home-page "http://jodies.de/ipcalc")
     (license license:gpl2+)))
+
+(define-public vde2
+  (package
+    (name "vde2")
+    (version "2.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "mirror://sourceforge/vde/vde2/2.3.2/vde2-2.3.2.tar.gz")
+       (sha256
+        (base32 "14xga0ib6p1wrv3hkl4sa89yzjxv7f1vfqaxsch87j6scdm59pr2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-build? #f))           ; Build fails if #t.
+    (inputs
+     `(("python" ,python)
+       ("libpcap" ,libpcap)
+       ("openssl" ,openssl-1.0)))       ; Build fails with 1.1.
+    (home-page "https://github.com/virtualsquare/vde-2")
+    (synopsis "Virtual Distributed Ethernet")
+    (description "VDE is a set of programs to provide virtual software-defined
+Ethernet network interface controllers across multiple virtual or
+physical, local or remote devices.  The VDE architecture provides
+virtual counterparts to hardware components such as switches and
+cables.")
+    (license (list license:gpl2
+                   license:lgpl2.1       ; libvdeplug
+                   (license:non-copyleft ; slirpvde
+                    "file://COPYING.slirpvde"
+                    "See COPYING.slirpvde in the distribution.")))))