diff mbox series

[bug#38489] gnu: Add r-qtl2.

Message ID 20191204085735.23318-1-efraim@flashner.co.il
State Accepted
Headers show
Series [bug#38489] gnu: Add r-qtl2. | expand

Commit Message

Efraim Flashner Dec. 4, 2019, 8:57 a.m. UTC
* gnu/packages/bioinformatics.scm (r-qtl2): New variable.
---
 gnu/packages/bioinformatics.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Simon Tournier Dec. 6, 2019, 6:14 p.m. UTC | #1
Hi Efraim,

On Wed, 4 Dec 2019 at 10:03, Efraim Flashner <efraim@flashner.co.il> wrote:
>
> * gnu/packages/bioinformatics.scm (r-qtl2): New variable.
> ---
>  gnu/packages/bioinformatics.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index b0d070b4e7..522cde959e 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -8239,6 +8239,35 @@ identify genotyping errors, and to perform single-QTL and two-QTL,
>  two-dimensional genome scans.")
>    (license license:gpl3)))
>
> +(define-public r-qtl2
> +  (package
> +    (name "r-qtl2")
> +    (version "0.20")
> +    (source (origin
> +      (method git-fetch)
> +      ;; Not yet available in cran.
> +      (uri (git-reference
> +             (url "https://github.com/rqtl/qtl2.git")
> +             (commit version)))
> +      (file-name (git-file-name name version))
> +      (sha256
> +       (base32 "0l1asr28q25jzbwrbg5490962sg3y4sjrd0qf09p78ws1aq8vfs0"))))
> +    (build-system r-build-system)
> +    (propagated-inputs
> +     `(("r-data-table" ,r-data-table)
> +       ("r-jsonlite" ,r-jsonlite)
> +       ("r-rcpp" ,r-rcpp)
> +       ("r-rcppeigen" ,r-rcppeigen)
> +       ("r-rsqlite" ,r-rsqlite)
> +       ("r-yaml" ,r-yaml)))
> +    (home-page "https://kbroman.org/qtl2/")
> +    (synopsis
> +     "QTL analysis software for high-dimensional data and complex cross designs")
> +    (description
> +     "R/qtl2 (aka qtl2) is a reimplementation of the QTL analysis software
> +R/qtl, to better handle high-dimensional data and complex cross designs.")
> +    (license license:gpl3)))
> +

LGTM.


All the best,
simon
Efraim Flashner Dec. 10, 2019, 11:12 a.m. UTC | #2
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b0d070b4e7..522cde959e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8239,6 +8239,35 @@  identify genotyping errors, and to perform single-QTL and two-QTL,
 two-dimensional genome scans.")
   (license license:gpl3)))
 
+(define-public r-qtl2
+  (package
+    (name "r-qtl2")
+    (version "0.20")
+    (source (origin
+      (method git-fetch)
+      ;; Not yet available in cran.
+      (uri (git-reference
+             (url "https://github.com/rqtl/qtl2.git")
+             (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "0l1asr28q25jzbwrbg5490962sg3y4sjrd0qf09p78ws1aq8vfs0"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-data-table" ,r-data-table)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppeigen" ,r-rcppeigen)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-yaml" ,r-yaml)))
+    (home-page "https://kbroman.org/qtl2/")
+    (synopsis
+     "QTL analysis software for high-dimensional data and complex cross designs")
+    (description
+     "R/qtl2 (aka qtl2) is a reimplementation of the QTL analysis software
+R/qtl, to better handle high-dimensional data and complex cross designs.")
+    (license license:gpl3)))
+
 (define-public r-zlibbioc
   (package
     (name "r-zlibbioc")