diff mbox series

[bug#38419] gnu: bitlbee: Use Python 3.

Message ID 20191128181641.5775-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#38419] gnu: bitlbee: Use Python 3. | expand

Commit Message

Timotej Lazar Nov. 28, 2019, 6:16 p.m. UTC
* gnu/packages/messaging.scm (bitlbee)[inputs]: Replace python-2 with python.
[arguments]: Set the PYTHON environment variable before configuring.
---
 gnu/packages/messaging.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Dec. 4, 2019, 5:13 p.m. UTC | #1
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

> * gnu/packages/messaging.scm (bitlbee)[inputs]: Replace python-2 with python.
> [arguments]: Set the PYTHON environment variable before configuring.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2429bad3e5..97b4eb85e1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -181,11 +182,13 @@  end-to-end encryption.")
     (inputs `(("glib" ,glib)
               ("libotr" ,libotr)
               ("gnutls" ,gnutls)
-              ("python" ,python-2)
+              ("python" ,python)
               ("perl" ,perl)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'set-python
+           (lambda _ (setenv "PYTHON" (which "python3")) #t))
          (add-after 'install 'install-etc
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
              (apply invoke "make" "install-etc" make-flags)))