diff mbox series

[bug#38344] gnu: Add qgo.

Message ID 20191123125654.16899-1-glv@posteo.net
State Accepted
Headers show
Series [bug#38344] gnu: Add qgo. | expand

Commit Message

Guillaume Le Vaillant Nov. 23, 2019, 12:56 p.m. UTC
* gnu/packages/games.scm (qgo): New variable.
---
 gnu/packages/games.scm | 71 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)

Comments

Guillaume Le Vaillant Nov. 24, 2019, 11:37 a.m. UTC | #1
Guillaume Le Vaillant skribis:

> * gnu/packages/games.scm (qgo): New variable.
> ---
>  gnu/packages/games.scm | 71 ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 71 insertions(+)

I found another fork of qGo called q5Go which might be better (more
features, more maintained). So let's not merge qGo right now. If
I succeed in getting q5Go packaged and working, I'll send a v2 patch for
q5Go to merge instead of the current qGo patch.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3d825cbe61..e97af7609e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7809,3 +7809,74 @@  remake of that series or any other game.")
 the AlphaGo Zero paper.  The current best network weights file for the engine
 can be downloaded from @url{https://zero.sjeng.org/best-network}.")
    (license license:gpl3+)))
+
+(define-public qgo
+  (let ((commit "2a4212d473372bb531fdc5c919a20dd96819f9b0")
+        (revision "0"))
+    (package
+      (name "qgo")
+      (version (git-version "2.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/pzorin/qgo.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0v03g0wp9vqzdn6ppxrhvabbz32ww83ipkk7178f8fqhm7ndvsbj"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("qttools" ,qttools)))
+      (inputs
+       `(("gnugo" ,gnugo)
+         ("qtbase" ,qtbase)
+         ("qtmultimedia" ,qtmultimedia)))
+      (arguments
+       `(#:modules ((guix build gnu-build-system)
+                    (guix build qt-utils)
+                    (guix build utils))
+         #:imported-modules (,@%gnu-build-system-modules
+                             (guix build qt-utils))
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-paths
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (substitute* "src/src.pro"
+                 (("= /usr/")
+                  (string-append "= " (assoc-ref outputs "out") "/"))
+                 (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
+                  (string-append (assoc-ref inputs "qttools") "/bin/lrelease")))
+               (substitute* "src/defines.h"
+                 (("/usr/games/")
+                  (string-append (assoc-ref inputs "gnugo") "/bin/"))
+                 (("/usr/share/")
+                  (string-append (assoc-ref outputs "out") "/share/")))
+               (substitute* "src/main.cpp"
+                 (("QCoreApplication::applicationDirPath\\(\\)\\+\"")
+                  (string-append "\"" (assoc-ref outputs "out") "/share/qgo")))
+               #t))
+           (replace 'configure
+             (lambda _
+               (invoke "qmake" "src")))
+           (add-after 'install 'install-translations
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((dest (string-append (assoc-ref outputs "out")
+                                          "/share/qgo/translations")))
+                 (for-each (lambda (file)
+                             (install-file file dest))
+                           (find-files "../source/src/translations/"
+                                       "qgo_.*\\.qm")))
+               #t))
+           (add-after 'install-translations 'wrap-program
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (wrap-qt-program out "qgo"))
+               #t)))))
+      (synopsis "Qt GUI to play the game of Go")
+      (description
+       "This is a Go client.  It supports playing online at IGS-compatible
+servers and locally against GTP-compliant engines like @code{gnugo}.
+It also has rudimentary support for editing SGF files.")
+      (home-page "https://github.com/pzorin/qgo")
+      (license license:gpl2+))))