diff mbox series

[bug#38259] gnu: Add r-harmony.

Message ID 20191118172216.21813-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38259] gnu: Add r-harmony. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 18, 2019, 5:22 p.m. UTC
* gnu/packages/bioinformatics.scm (r-harmony): New variable.
---
 gnu/packages/bioinformatics.scm | 38 ++++++++++++++++++++++++++++++++-
 1 file changed, 37 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Nov. 21, 2019, 10:47 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> skribis:

>     * gnu/packages/bioinformatics.scm (r-harmony): New variable.

It took me a while but I then realized the package was already in, only
in a different file, cran.scm.

So I’ve not pushed your version, but let us know if you’d like to change
the existing package!

Thanks,
Ludo’.
Simon Tournier Nov. 21, 2019, 10:58 a.m. UTC | #2
Hi,

On Thu, 21 Nov 2019 at 11:48, Ludovic Courtès <ludo@gnu.org> wrote:

> It took me a while but I then realized the package was already in, only
> in a different file, cran.scm.

IMHO, some packages need to be moved in the right files.
For example this one. It is not a CRAN package because it does not
come from the CRAN archive but a Bioinformatics one written in R
language.


In the same topic, I moved [1] packages fetched from the CRAN archive
to the cran.scm file.

[1] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38184


To me, keeping a clear file organisation helps. :-)


All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 07c70fb82c..5da95d66a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;;
@@ -15349,3 +15349,39 @@  methylation metrics from them.  MethylDackel requires an indexed fasta file
 containing the reference genome as well.")
     ;; See https://github.com/dpryan79/MethylDackel/issues/85
     (license license:expat)))
+
+(define-public r-harmony
+  (let ((commit "1a6d77aae524a08a2ca91737a152ab2047ccee78")
+        (revision "1"))
+    (package
+      (name "r-harmony")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/immunogenomics/harmony.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1905qsbl5iv3kxki73gmyzshyb8zc6asdaymywndscn7mjkwm7aw"))))
+      (build-system r-build-system)
+      (propagated-inputs
+       `(("r-cowplot" ,r-cowplot)
+         ("r-dplyr" ,r-dplyr)
+         ("r-ggplot2" ,r-ggplot2)
+         ("r-irlba" ,r-irlba)
+         ("r-matrix" ,r-matrix)
+         ("r-rcpp" ,r-rcpp)
+         ("r-rcpparmadillo" ,r-rcpparmadillo)
+         ("r-rcppprogress" ,r-rcppprogress)
+         ("r-rlang" ,r-rlang)
+         ("r-tibble" ,r-tibble)
+         ("r-tidyr" ,r-tidyr)))
+      (home-page "https://github.com/immunogenomics/harmony.git")
+      (synopsis "Fast, sensitive, and accurate integration of single cell data")
+      (description
+       "Harmony software is the R implementation of the algorithm with the same
+name for single cell integration, described in Korsunsky et al 2018.  Package
+includes a standalone Harmony function and interfaces to external frameworks.")
+      (license license:gpl3))))