diff mbox series

[bug#38184,2/4] gnu: r-pracma: Move to (gnu packages cran).

Message ID 20191112191533.32371-3-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#38184,1/4] gnu: r-quadprog: Move to (gnu packages cran). | expand

Commit Message

Simon Tournier Nov. 12, 2019, 7:15 p.m. UTC
* gnu/packages/maths.scm (r-pracma): Move from here...
* gnu/packages/cran.scm (r-pracma): ...to here.
---
 gnu/packages/cran.scm  | 23 ++++++++++++++++++++++-
 gnu/packages/maths.scm | 18 ------------------
 2 files changed, 22 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 67959c9280..ed416c4a8e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017, 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
@@ -15666,3 +15666,24 @@  data.table.")
      "This package contains routines and documentation for solving quadratic
 programming problems.")
     (license license:gpl3+)))
+
+(define-public r-pracma
+  (package
+    (name "r-pracma")
+    (version "2.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pracma" version))
+       (sha256
+        (base32
+         "0isd3s0i4mzmva8lkh0j76hwjy1w50q7d1n9lhxsnnkgalx3xs1g"))))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/pracma/")
+    (synopsis "Practical numerical math functions")
+    (description
+     "This package provides functions for numerical analysis and
+linear algebra, numerical optimization, differential equations, plus some
+special functions.  It uses Matlab function names where appropriate to simplify
+porting.")
+    (license license:gpl3+)))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a4452af93e..3565b99e05 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2341,24 +2341,6 @@  sparse system of linear equations A x = b using Gaussian elimination.")
     (inputs
      (alist-delete "pt-scotch" (package-inputs mumps-openmpi)))))
 
-(define-public r-pracma
-  (package
-    (name "r-pracma")
-    (version "2.2.5")
-    (source (origin
-      (method url-fetch)
-      (uri (cran-uri "pracma" version))
-      (sha256
-        (base32 "0isd3s0i4mzmva8lkh0j76hwjy1w50q7d1n9lhxsnnkgalx3xs1g"))))
-    (build-system r-build-system)
-    (home-page "https://cran.r-project.org/web/packages/pracma/")
-    (synopsis "Practical numerical math functions")
-    (description "This package provides functions for numerical analysis and
-linear algebra, numerical optimization, differential equations, plus some
-special functions.  It uses Matlab function names where appropriate to simplify
-porting.")
-    (license license:gpl3+)))
-
 (define-public ruby-asciimath
   (package
     (name "ruby-asciimath")