diff mbox series

[bug#38060] gnu: CMake: Update to 3.15.5.

Message ID 20191112052811.GR17621@sax.terramar.selidor.net
State Accepted
Headers show
Series [bug#38060] gnu: CMake: Update to 3.15.5. | expand

Commit Message

Ivan Vilata i Balaguer Nov. 12, 2019, 5:28 a.m. UTC
Marius Bakke (2019-11-11 00:00:10 +0100) wrote:

> Ivan: if you need the newer CMake on 'master', can you submit a patch
> that adds a separate 'cmake-3.15.5' variable?  Then you can use that in
> cmake-build-system with '#:cmake ,cmake-3.15.5'.

Sure, I'm attaching the patch which I tried and seemed to work (at least for
installing `cmake@3.15.5` explicitly and using it).

Is it ok like this or shall I send it to guix-patches?

Cheers,

Comments

Marius Bakke Nov. 15, 2019, 6:17 p.m. UTC | #1
Ivan Vilata i Balaguer <ivan@selidor.net> writes:

> Marius Bakke (2019-11-11 00:00:10 +0100) wrote:
>
>> Ivan: if you need the newer CMake on 'master', can you submit a patch
>> that adds a separate 'cmake-3.15.5' variable?  Then you can use that in
>> cmake-build-system with '#:cmake ,cmake-3.15.5'.
>
> Sure, I'm attaching the patch which I tried and seemed to work (at least for
> installing `cmake@3.15.5` explicitly and using it).
>
> Is it ok like this or shall I send it to guix-patches?

Attaching patches to bug reports is fine.  Pushed as
528b52390d216d8a8cd13dfcd1e6e40a6448e6c2.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..e2c244c1a7 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -219,6 +219,22 @@  and workspaces that can be used in the compiler environment of your choice.")
                (append (search-patches "cmake-curl-certificates.patch")
                        (origin-patches (package-source cmake))))))))
 
+(define-public cmake-3.15.5
+  ;; CMake 3.15.5 fixes some issues, but declare another version to
+  ;; avoid triggering the rebuild of all CMake-based packages.
+  ;; See <https://issues.guix.gnu.org/issue/38060>.
+  (package
+    (inherit cmake)
+    (version "3.15.5")
+    (source (origin
+              (inherit (package-source cmake))
+              (uri (string-append "https://www.cmake.org/files/v"
+                                  (version-major+minor version)
+                                  "/cmake-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
+
 (define-public emacs-cmake-mode
   (package
     (inherit cmake)