diff mbox series

[bug#38123,1/1] gnu: qtwebkit: Uses sqlite-with-column-metadata.

Message ID 20191108103843.8731-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series qtwebkit: Uses sqlite-with-column-metadata | expand

Commit Message

Hartmut Goebel Nov. 8, 2019, 10:38 a.m. UTC
This needs to be the same variant as for qtbase, otherwise applications
might fail if libQt5WebKit is loaded prior to libQt5Sql.

* gnu/packages/qt.scm(wtwebkit)[inputs]: Replace sqlite by
  sqlite-with-column-metadata.
---
 gnu/packages/qt.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Marius Bakke Nov. 9, 2019, 11:01 p.m. UTC | #1
Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> This needs to be the same variant as for qtbase, otherwise applications
> might fail if libQt5WebKit is loaded prior to libQt5Sql.
>
> * gnu/packages/qt.scm(wtwebkit)[inputs]: Replace sqlite by
>   sqlite-with-column-metadata.

LGTM.  I think we should enable column metadata in the regular SQLite
package this upcoming 'core-updates' round.

Thoughts?
Efraim Flashner Nov. 10, 2019, 7:23 a.m. UTC | #2
On Sun, Nov 10, 2019 at 12:01:24AM +0100, Marius Bakke wrote:
> Hartmut Goebel <h.goebel@crazy-compilers.com> writes:
> 
> > This needs to be the same variant as for qtbase, otherwise applications
> > might fail if libQt5WebKit is loaded prior to libQt5Sql.
> >
> > * gnu/packages/qt.scm(wtwebkit)[inputs]: Replace sqlite by
> >   sqlite-with-column-metadata.
> 
> LGTM.  I think we should enable column metadata in the regular SQLite
> package this upcoming 'core-updates' round.
> 
> Thoughts?

Core-updates is open. I don't see any reason to delay merging the two
any longer
Hartmut Goebel Nov. 10, 2019, 8:28 p.m. UTC | #3
Pushed to staging as 8bfd7c8beb75ed3838efdf5973b9db5fb3ced68c
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0ef879678f..222a0cc867 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2182,7 +2182,7 @@  different kinds of sliders, and much more.")
        ("libjpeg" ,libjpeg)
        ("libpng" ,libpng)
        ("libwebp" ,libwebp)
-       ("sqlite" ,sqlite)
+       ("sqlite" ,sqlite-with-column-metadata)
        ("fontconfig" ,fontconfig)
        ("libxrender" ,libxrender)
        ("qtbase" ,qtbase)