diff mbox series

[bug#38122,012/197] gnu: pingus: Adjust for GCC 7.

Message ID 20191108103434.8390-13-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#38122,001/197] gnu: Add emacs-eshell-prompt-extras. | expand

Commit Message

Hartmut Goebel Nov. 8, 2019, 10:33 a.m. UTC
From: Marius Bakke <mbakke@fastmail.com>

Fixes <https://bugs.gnu.org/37946>.

* gnu/packages/games.scm (pingus)[source](modules, snippet): New fields.
---
 gnu/packages/games.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 04b06c88ee..a2917a5f23 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1445,7 +1445,16 @@  fight Morgoth, the Lord of Darkness.")
         (base32
          "0wp06kcmknsnxz7bjnsndb8x062z7r23fb3yrnbfnj68qhz18y74"))
        (patches (search-patches "pingus-boost-headers.patch"
-                                "pingus-sdl-libs-config.patch"))))
+                                "pingus-sdl-libs-config.patch"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (substitute* "src/pingus/screens/demo_session.cpp"
+             (("#include <iostream>")
+              ;; std::function moved to <functional> with C++ 11.
+              ;; Remove this for versions newer than 0.7.6.
+              "#include <iostream>\n#include <functional>"))
+           #t))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("scons-python2" ,scons-python2)))