diff mbox series

[bug#38096] gnu: packages: Add rofi-pass.

Message ID 20191107081336.11498-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#38096] gnu: packages: Add rofi-pass. | expand

Commit Message

Tanguy LE CARROUR Nov. 7, 2019, 8:13 a.m. UTC
* gnu/packages/xdisorg.scm (rofi-pass): New public variable.
---
 gnu/packages/xdisorg.scm | 45 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

Comments

Mathieu Othacehe Nov. 7, 2019, 10:07 a.m. UTC | #1
Hello Tanguy,

> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm

I think this should go to password-utils.scm.

Mathieu
Tanguy LE CARROUR Nov. 7, 2019, 4:48 p.m. UTC | #2
Hi Mathieu,


Le 11/07, Mathieu Othacehe a écrit :
> 
> Hello Tanguy,
> 
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> 
> I think this should go to password-utils.scm.

I had a 50-50 chance… and picked the wrong one! ^_^'

I'm sending v2! Thanks for reviewing.
Mathieu Othacehe Nov. 8, 2019, 9:01 p.m. UTC | #3
Hello,

I pushed this patch with an edited synopsis and a small typo fixed in
description field.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 772e09d5b2..df13437d3c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -56,6 +56,7 @@ 
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages admin)
@@ -77,6 +78,7 @@ 
   #:use-module (gnu packages maths)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages password-utils)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -1269,6 +1271,49 @@  applications you regularly use and also allows you to search for an application
 by name.")
     (license license:expat)))
 
+(define-public rofi-pass
+  (package
+    (name "rofi-pass")
+    (version "2.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://raw.githubusercontent.com/carnager/rofi-pass/"
+                       version "/rofi-pass"))
+       (sha256
+        (base32 "0msldkndqp40nx1s5s7ggcr97ir4nshpmnyzvj5hqw1l7m3gvw6j"))
+       (file-name name)))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((source (string-append (assoc-ref %build-inputs "source")))
+               (script "rofi-pass")
+               (out (assoc-ref %outputs "out")))
+           (copy-file source script)
+           (chmod script #o555)
+           (install-file script (string-append out "/bin"))))))
+    (propagated-inputs
+     `(("password-store" ,password-store)
+       ("rofi" ,rofi)
+       ("xdotool" ,xdotool)))
+    (home-page "https://github.com/carnager/rofi-pass")
+    (synopsis "Handle Simple Password Store in a convenient way using rofi")
+    (description "Rofi-pass provides a way to maniplutate information stored
+using password-store through rofi interface:
+@enumerate
+@item open URLs of entries with hotkey;
+@item type any field from entry;
+@item auto-typing of user and/or password fields;
+@item auto-typing username based on path;
+@item auto-typing of more than one field, using the autotype entry;
+@item bookmarks mode (open stored URLs in browser, default: Alt+x).
+@end enumerate")
+    (license license:gpl3)))
+
 (define-public tint2
   (package
     (name "tint2")