diff mbox series

[bug#38090,1/2] gnu: astyle: Install header file, too.

Message ID 20191106164038.10010-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Fix build for astyle | expand

Commit Message

Hartmut Goebel Nov. 6, 2019, 4:40 p.m. UTC
* gnu/packages/code.scm(astyle)[arguments]<phases>{install-libs}: Also install
  header file.
---
 gnu/packages/code.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 512ca5d365..d1c3540bd4 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@goebel-consult.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -605,10 +606,14 @@  Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
            (lambda _ (chdir "build/gcc") #t))
          (add-after 'install 'install-libs
            (lambda* (#:key outputs #:allow-other-keys)
-             ;; Libraries are not installed by default
+             ;; Libraries and includes are not installed by default
              (let* ((output (assoc-ref outputs "out"))
+                    (incdir (string-append output "/include"))
                     (libdir (string-append output "/lib")))
                (begin
+                 (mkdir-p incdir)
+                 (copy-file "../../src/astyle.h"
+                            (string-append incdir "/astyle.h"))
                  (mkdir-p libdir)
                  (for-each (lambda (l)
                              (copy-file