diff mbox series

[bug#38073] gnu: grantlee: Fix build for Qt 5.12.

Message ID 20191105210043.21445-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#38073] gnu: grantlee: Fix build for Qt 5.12. | expand

Commit Message

Hartmut Goebel Nov. 5, 2019, 9 p.m. UTC
Build using gnu++11 standard.

* gnu/packages/qt.scm(grantlee)[argument]<configure-flags>: New
  element.
---
 gnu/packages/qt.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Nov. 6, 2019, 7:09 a.m. UTC | #1
Looks good to me. Assuming it builds go ahead and push it to master or
staging, whichever is better for it.
Hartmut Goebel Nov. 6, 2019, 9:31 a.m. UTC | #2
Am 06.11.19 um 08:09 schrieb Efraim Flashner:
> Looks good to me. Assuming it builds go ahead and push it to master or
> staging, whichever is better for it.
>
>
Pushed to staging, as Qt 5.12 is not yet in master.

ea57bb893eeb7008064d2f511dede616d4bdcbd1

Thanks for the review.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8928c1ddd4..0ef879678f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -100,7 +100,8 @@ 
        ("qtscript" ,qtscript)))
     (build-system cmake-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("-DCMAKE_CXX_STANDARD=11")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'delete-broken-tests
            (lambda _