diff mbox series

[bug#38030,13/13,v2] gnu: kpmcore: Update to 4.0.1

Message ID 20191105205530.20969-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series None | expand

Commit Message

Hartmut Goebel Nov. 5, 2019, 8:55 p.m. UTC
Also move to kde.scm, since it is not a framework part.

* gnu/packages/kde-frameworks.scm(kpmcore): Move from here …
* gnu/packages/kde.scm(kpmcore): … to here, update to 4.0.1; [inputs]: Add
  qttools, remove kiconthemes, kservice, libatasmart, parted; [arguments]: New
  element.
---
 gnu/packages/kde-frameworks.scm | 33 ------------------------------
 gnu/packages/kde.scm            | 36 +++++++++++++++++++++++++++++++++
 2 files changed, 36 insertions(+), 33 deletions(-)

Comments

Marius Bakke Nov. 9, 2019, 11:09 p.m. UTC | #1
Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> Also move to kde.scm, since it is not a framework part.
>
> * gnu/packages/kde-frameworks.scm(kpmcore): Move from here …
> * gnu/packages/kde.scm(kpmcore): … to here, update to 4.0.1; [inputs]: Add
>   qttools, remove kiconthemes, kservice, libatasmart, parted; [arguments]: New
>   element.
> ---
>  gnu/packages/kde-frameworks.scm | 33 ------------------------------
>  gnu/packages/kde.scm            | 36 +++++++++++++++++++++++++++++++++
>  2 files changed, 36 insertions(+), 33 deletions(-)

I'd prefer if the move was done in a separate commit, to clarify the
changes done.

[...]

> +    (arguments
> +     ;; tests segfault, see <https://bugs.kde.org/show_bug.cgi?id=413851>,
> +     ;; remaining "testsmart" hangs. As of 4.0.1 tests are a farce anyway.
> +     '(#:tests? #f))

It looks like this was fixed upstream (thanks!).  Can we apply that
patch instead?

I did not look closely at the changes due to the mega-diff, but I trust
your judgement here.  :-)
Hartmut Goebel Nov. 10, 2019, 9:20 p.m. UTC | #2
> I'd prefer if the move was done in a separate commit, to clarify the
> changes done.

Fine for me, done.

> It looks like this was fixed upstream (thanks!).  Can we apply that
> patch instead?
Done.
> I did not look closely at the changes due to the mega-diff, but I trust
> your judgement here.  :-)


:-))

Pushed as 38988dbecf9e1ee83258c5625bb8fdacff82ed3d
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d4f2ccc903..96aba546aa 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -41,7 +41,6 @@ 
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
-  #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freedesktop)
@@ -214,38 +213,6 @@  Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
     ;; license: source files mention "either version 2.1 or 3"
     (license (list license:lgpl2.1 license:lgpl3))))
 
-(define-public kpmcore
-  (package
-    (name "kpmcore")
-    (version "3.3.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://kde/stable/kpmcore"
-                    "/" version "/src/"
-                    name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0s6v0jfrhjg31ri5p6h9n4w29jvasf5dj954j3vfpzl91lygmmmq"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("kconfigwidgets" ,kconfigwidgets)
-       ("kiconthemes" ,kiconthemes)
-       ("kio" ,kio)
-       ("ki18n" ,ki18n)
-       ("kservice" ,kservice)
-       ("libatasmart" ,libatasmart)
-       ("parted" ,parted)
-       ("qtbase" ,qtbase)
-       ("util-linux" ,util-linux)))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Library for managing partitions")
-    (description "Library for managing partitions.")
-    (license license:gpl3+)))
-
 
 ;; Tier 1
 ;;
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6193d6eb07..8cc4e145b4 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,10 +1,12 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -42,6 +44,7 @@ 
   #:use-module (gnu packages image)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages kde-plasma)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages pdf)
@@ -464,6 +467,39 @@  including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
 cards.")
     (license license:lgpl2.1)))
 
+(define-public kpmcore
+  (package
+    (name "kpmcore")
+    (version "4.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/kpmcore"
+                    "/" version "/src/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; tests segfault, see <https://bugs.kde.org/show_bug.cgi?id=413851>,
+     ;; remaining "testsmart" hangs. As of 4.0.1 tests are a farce anyway.
+     '(#:tests? #f))
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("kconfigwidgets" ,kconfigwidgets)
+       ("kio" ,kio)
+       ("ki18n" ,ki18n)
+       ("qtbase" ,qtbase)
+       ("qca" ,qca)
+       ("util-linux" ,util-linux)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Library for managing partitions")
+    (description "Library for managing partitions.")
+    (license license:gpl3+)))
+
 (define-public snorenotify
   (package
     (name "snorenotify")