diff mbox series

[bug#38063,1/2] gnu: Add m2-planet.

Message ID 20191104224243.19953-1-janneke@gnu.org
State Accepted
Headers show
Series gnu: Add m2-planet-boot0. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 4, 2019, 10:42 p.m. UTC
* gnu/packages/mes.scm (m2-planet): New variable.
---
 gnu/packages/mes.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Ludovic Courtès Nov. 13, 2019, 10:22 p.m. UTC | #1
Hello,

Jan Nieuwenhuizen <janneke@gnu.org> skribis:

> * gnu/packages/mes.scm (m2-planet): New variable.

[...]

> +      (synopsis "The PLAtform NEutral Transpiler")
> +      (description
> +       "M2-Planet, The PLAtform NEutral Transpiler, when combined with
> +mescc-tools compiles a subset of the C language into working binaries
> +with introspective steps inbetween.")

It would be awesome if you could add one or two sentences here.

Regardless it LGTM!

Thanks,
Ludo’.
Janneke Nieuwenhuizen Nov. 14, 2019, 3:48 p.m. UTC | #2
Ludovic Courtès writes:

>> +      (description
>> +       "M2-Planet, The PLAtform NEutral Transpiler, when combined with
>> +mescc-tools compiles a subset of the C language into working binaries
>> +with introspective steps inbetween.")
>
> It would be awesome if you could add one or two sentences here.

I added two sentences:

      (description
       "M2-Planet, the PLAtform NEutral Transpiler, when combined with
mescc-tools, compiles a subset of the C language into working binaries with
introspective steps inbetween.  It is self-hosting and for bootstrapping it
also has an implementation in the M1 macro assembly language.  M2-Planet is
built as Phase-5 of the full source bootstrapping process and is capable of
building GNU Mes.")

> Regardless it LGTM!

Closed and pushed to master as 99b340f5eeb742d966dd16b1bfd7d2b308edc75f

Thanks,
janneke
diff mbox series

Patch

diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 3174c0c115..55d731d876 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -204,3 +204,35 @@  get_machine.")
        ((#:make-flags _)
         `(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
                "CC=gcc"))))))
+
+(define-public m2-planet
+  (let ((commit "1fc2aeab483208bd2ba117b21df3894c182470ec")
+        (revision "0"))
+    (package
+      (name "m2-planet")
+      (version (string-append "1.4.0-" revision "." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/oriansj/m2-planet.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1fj3xiqcibdfi78b43nn6w8hs3vkz32yb06n8r5mna8pnjdmn00l"))))
+      (native-inputs
+       `(("mescc-tools" ,mescc-tools)))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+         #:tests? #f
+         #:phases (modify-phases %standard-phases
+                    (delete 'bootstrap)
+                    (delete 'configure))))
+      (synopsis "The PLAtform NEutral Transpiler")
+      (description
+       "M2-Planet, The PLAtform NEutral Transpiler, when combined with
+mescc-tools compiles a subset of the C language into working binaries
+with introspective steps inbetween.")
+      (home-page "https://github.com/oriansj/m2-planet")
+      (license gpl3+))))