diff mbox series

[bug#38060] gnu: CMake: Update to 3.15.5.

Message ID 20191104165746.GJ17621@sax.terramar.selidor.net
State Accepted
Headers show
Series [bug#38060] gnu: CMake: Update to 3.15.5. | expand

Commit Message

Ivan Vilata i Balaguer Nov. 4, 2019, 4:57 p.m. UTC
This patch updates CMake to version 3.15.5, which fixes some bugs as listed
here: <https://cmake.org/cmake/help/v3.15/release/3.15.html#updates>

I've been trying the package built from this patch for some days and it seems
to work ok and indeed fix the issues that were affecting us.

Thanks and cheers!

Comments

Mathieu Othacehe Nov. 5, 2019, 7:52 a.m. UTC | #1
Hello!

> I've been trying the package built from this patch for some days and it seems
> to work ok and indeed fix the issues that were affecting us.

Your patch seems fine. However, I think it will cause a rebuild of all
cmake based packages (even though they are not listed by guix refresh
-l). So I think we need to wait for the next staging cycle.

Marius, is that correct?

Mathieu
Marius Bakke Nov. 10, 2019, 11 p.m. UTC | #2
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> Hello!
>
>> I've been trying the package built from this patch for some days and it seems
>> to work ok and indeed fix the issues that were affecting us.
>
> Your patch seems fine. However, I think it will cause a rebuild of all
> cmake based packages (even though they are not listed by guix refresh
> -l). So I think we need to wait for the next staging cycle.
>
> Marius, is that correct?

Indeed.

Ivan: if you need the newer CMake on 'master', can you submit a patch
that adds a separate 'cmake-3.15.5' variable?  Then you can use that in
cmake-build-system with '#:cmake ,cmake-3.15.5'.
diff mbox series

Patch

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..7ab50aa336 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -50,7 +50,7 @@ 
 (define-public cmake-minimal
   (package
     (name "cmake-minimal")
-    (version "3.15.1")
+    (version "3.15.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.cmake.org/files/v"
@@ -58,7 +58,7 @@ 
                                   "/cmake-" version ".tar.gz"))
               (sha256
                (base32
-                "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+                "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
               (modules '((guix build utils)))
               (snippet
                '(begin