diff mbox series

[bug#38029,15/80] gnu: Add python-dbusmock.

Message ID 20191102014348.3191-6-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#38029,01/80] gnu: adwaita-icon-theme: Update to 3.32.0. | expand

Commit Message

Kei Kebreau Nov. 2, 2019, 1:43 a.m. UTC
* gnu/packages/python-xyz.scm (python-dbusmock): New variable.
---
 gnu/packages/python-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 39 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10fe5ee553..56b43c73cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -41,7 +41,7 @@ 
 ;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
 ;;; Copyright © 2017, 2019 Brendan Tildesley <mail@brendan.scot>
@@ -102,6 +102,7 @@ 
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages gstreamer)
@@ -16487,3 +16488,40 @@  It is the recommended replacement for Python's original
 @code{distro} also provides a command-line interface to output the platform
 information in various formats.")
     (license license:asl2.0)))
+
+(define-public python-dbusmock
+  (package
+  (name "python-dbusmock")
+  (version "0.18.1")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "python-dbusmock" version))
+      (sha256
+        (base32
+          "1hj02p65cic4jdc6a5xf1hx8j5icwy7dcrm5kg91lkjks4gwpg5h"))))
+  (build-system python-build-system)
+  (arguments
+   '(#:phases
+     (modify-phases %standard-phases
+       (add-after 'unpack 'patch-/bin/sh
+         (lambda _
+           (substitute* "tests/test_code.py"
+             (("/bin/sh") (which "sh")))
+           #t)))))
+  (native-inputs
+   `(;; For tests.
+     ("dbus" ,dbus) ; for dbus-daemon
+     ("python-nose" ,python-nose)
+     ("which" ,which)))
+  (propagated-inputs
+   `(("python-dbus" ,python-dbus)
+     ("python-pygobject" ,python-pygobject)))
+  (home-page "https://github.com/martinpitt/python-dbusmock")
+  (synopsis "Python library for mock D-Bus objects")
+  (description "python-dbusmock allows for the easy creation of mock objects on
+D-Bus.  This is useful for writing tests for software which talks to D-Bus
+services such as upower, systemd, logind, gnome-session or others, and it is
+hard (or impossible without root privileges) to set the state of the real
+services to what you expect in your tests.")
+  (license license:lgpl3+)))