diff mbox series

[bug#38018] gnu: Add emacs-leaf

Message ID 20191101114602.31959-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#38018] gnu: Add emacs-leaf | expand

Commit Message

Leo Prikler Nov. 1, 2019, 11:46 a.m. UTC
* gnu/packages/emacs-xyz: (emacs-leaf): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Mathieu Othacehe Nov. 4, 2019, 9:13 a.m. UTC | #1
Hello Leo,

I fixed the indentation, added your copyright and pushed your patch :)

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f584f72b7..0b206121b2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8959,6 +8959,36 @@  configuration in your @file{.emacs} file in a way that is both
 performance-oriented and tidy.")
     (license license:gpl2+)))
 
+(define-public emacs-leaf
+  (package
+   (name "emacs-leaf")
+   (version "3.5.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/conao3/leaf.el.git")
+           (commit (string-append "v" version))))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "1rgd59146wad92yc64las0qgx67k2ifgsw1vwhp40xvkd7kb0r6d"))))
+   (build-system emacs-build-system)
+   (home-page "https://github.com/conao3/leaf.el")
+   (arguments
+    `(#:tests? #t
+      #:test-command '("emacs" "--batch"
+                       "-l" "leaf-tests.el"
+                       "-f" "cort-test-run")))
+   (synopsis
+    "Simplify your init.el configuration, extended use-package")
+   (description
+    "Provides macros that allow you to declaratively configure settings typical
+of an Elisp package with various keywords.  The syntax is similar, but not
+identical to use-package -- overall, leaf aims at a cleaner and more predictable
+implementation.")
+   (license license:agpl3+)))
+
 (define-public emacs-strace-mode
   (let* ((commit "6a69b4b06db6797af56f33eda5cb28af94e59f11")
          (revision "1"))