diff mbox series

[bug#37988,v2,4/6] gnu: Add r-cytolib.

Message ID 20191030124224.29391-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Simon Tournier Oct. 30, 2019, 12:42 p.m. UTC
* gnu/packages/bioconductor.scm (r-cytolib): New variable.
---
 gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7c1761852c..00b10918ff 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6205,3 +6205,26 @@  data.")
     (description "This package provides the headers and static library of
 Protocol buffers 2.6.0 for other R packages to compile and link against.")
     (license license:bsd-3)))
+
+(define-public r-cytolib
+  (package
+    (name "r-cytolib")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "cytolib" version))
+       (sha256
+        (base32
+         "10sdkwrmzmp3sh59hl3x0zxwlw77v80jnv8gz1qrv66skjb764cq"))))
+    (properties
+     `((upstream-name . "cytolib")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-rprotobuflib" ,r-rprotobuflib)))
+    (home-page "https://bioconductor.org/packages/cytolib")
+    (synopsis "Infrastructure for working with gated cytometry data")
+    (description "This package provides the core data structure and API to
+represent and interact with gated cytometry data.")
+    (license license:artistic2.0)))