diff mbox series

[bug#37963] gnu: scdoc: Set PREFIX instead of patching Makefile.

Message ID 20191028154633.3483-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#37963] gnu: scdoc: Set PREFIX instead of patching Makefile. | expand

Commit Message

Brendan Tildesley Oct. 28, 2019, 3:46 p.m. UTC
scdoc installs a scdoc.pc file in lib/pkgconfig, but it embeds
prefix=/usr/local unless the Makefile was patched before 'build. However, it
seemed better to simply set the PREFIX make-flag instead, since the Makefile
correctly checks for it. Diffoscope shows the output is identical with either
method.

* gnu/packages/man.scm (scdoc)[arguments]: Set PREFIX instead of patching
Makefile with output path.
---
 gnu/packages/man.scm | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

Comments

Marius Bakke Oct. 28, 2019, 10:01 p.m. UTC | #1
Brendan Tildesley <mail@brendan.scot> writes:

> scdoc installs a scdoc.pc file in lib/pkgconfig, but it embeds
> prefix=/usr/local unless the Makefile was patched before 'build. However, it
> seemed better to simply set the PREFIX make-flag instead, since the Makefile
> correctly checks for it. Diffoscope shows the output is identical with either
> method.
>
> * gnu/packages/man.scm (scdoc)[arguments]: Set PREFIX instead of patching
> Makefile with output path.

Good catch, applied!
diff mbox series

Patch

diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index de2377a14e..dc55e0a4ed 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -251,15 +251,11 @@  automatically.")
        "00zc3rzj97gscby31djlqyczvqpyhrl66i44czwzmmn7rc5j03m1"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:make-flags '("CC=gcc")
+    `(#:make-flags
+      (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
       #:phases
       (modify-phases %standard-phases
-        (delete 'configure)
-        (add-before 'install 'hardcode-paths
-          (lambda* (#:key outputs #:allow-other-keys)
-            (substitute* "Makefile"
-                         (("/usr/local") (assoc-ref outputs "out")))
-            #t)))))
+        (delete 'configure))))
    (home-page "https://git.sr.ht/~sircmpwn/scdoc")
    (synopsis "Simple man page generator")
    (description "scdoc is a simple man page generator written for POSIX systems