diff mbox series

[bug#37704,v4,4/9] gnu: Add python-memcached.

Message ID 20191028144137.19982-4-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#37704,v4,1/9] gnu: python-cleo: Update to 0.6.8. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2019, 2:41 p.m. UTC
* gnu/packages/python-xyz.scm (python-memcached): New public variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa534badda..9b7b3cd8b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10659,6 +10659,28 @@  implementation as been adapted, improved and fixed from Molten.")
 running in.")
     (license license:isc)))
 
+(define-public python-memcached
+  (package
+    (name "python-memcached")
+    (version "1.59")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-memcached" version))
+       (sha256
+        (base32
+         "0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))))
+    (build-system python-build-system)
+    (propagated-inputs `(("python-six" ,python-six)))
+    (home-page
+     "https://github.com/linsomniac/python-memcached")
+    (synopsis "Pure python memcached client")
+    (description
+     "This software is a 100% Python interface to the memcached memory cache
+daemon.  It is the client side software which allows storing values in one or
+more, possibly remote, memcached servers.")
+    (license license:psfl)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")