diff mbox series

[bug#37923,1/2] gnu: profanity: Add configure flags and inputs for better defaults.

Message ID 20191025152040.25196-1-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: profanity: Add configure flags and inputs for better defaults. | expand

Commit Message

Tanguy LE CARROUR Oct. 25, 2019, 3:20 p.m. UTC
* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-omemo, --enable-notifications and --enable-icon.
[native-inputs]: Add libnotify and libsignal-protocol-c.
---
 gnu/packages/messaging.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Mathieu Othacehe Oct. 25, 2019, 5:25 p.m. UTC | #1
Hey Tanguy,

Much better with git send-email ;) A few remarks below:

> +     `(#:configure-flags
         ^
It can be ' because there are no unquoting in the following list.

> +             "--enable-icon"
                              ^
I think it is --enable-icons but that triggers missing inputs. You can
have a look to nix recipe if needed.

Thanks,

Mathieu
Tanguy LE CARROUR Oct. 26, 2019, 4:12 p.m. UTC | #2
Hi Mathieu,


Le 10/25, Mathieu Othacehe a écrit :
> Much better with git send-email ;) A few remarks below:
> 
> > +     `(#:configure-flags
>          ^
> It can be ' because there are no unquoting in the following list.

Done!


> > +             "--enable-icon"
>                               ^
> I think it is --enable-icons but that triggers missing inputs. You can
> have a look to nix recipe if needed.

Outch! Sorry for that! Actually when I added it I thought "if I don't
spell it properly, configure will fail, won't it?"… obviously I was
wrong! ^_^'


v2 is following.

I also added "--enable-c-plugins" and "--enable-otr" with the comment
from Nix expression ("Enable feature flags, so that build fail if libs
are missing") in the commit message. And I added "--enable-pgp" in
a separate commit… but I guess you'll squash everything together, right?

I tried to add "--enable-python-plugins" and "python" as a native input,
but it did not work! So, for now, I left it out.

Thanks again for reviewing!
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f890ad8dd5..ca01a4492e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1627,6 +1627,11 @@  are both supported).")
                (base32
                 "0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "--enable-omemo"
+             "--enable-icon"
+             "--enable-notifications")))
     (inputs
      `(("curl" ,curl)
        ("expat" ,expat)
@@ -1642,7 +1647,9 @@  are both supported).")
        ("autoconf-archive" ,autoconf-archive)
        ("automake" ,automake)
        ("cmocka" ,cmocka)
+       ("libnotify" ,libnotify)
        ("libtool" ,libtool)
+       ("libsignal-protocol-c" ,libsignal-protocol-c)
        ("pkg-config" ,pkg-config)))
     (synopsis "Console-based XMPP client")
     (description "Profanity is a console based XMPP client written in C