diff mbox series

[bug#37853,v2] gnu: Add ddcci-driver-linux.

Message ID 20191025093223.31672-2-brice@waegenei.re
State Accepted
Headers show
Series [bug#37853,v2] gnu: Add ddcci-driver-linux. | expand

Commit Message

Brice Waegeneire Oct. 25, 2019, 9:32 a.m. UTC
* gnu/packages/linux.scm (ddcci-driver-linux): Add variable.
---
 gnu/packages/linux.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

Mathieu Othacehe Oct. 25, 2019, 9:50 a.m. UTC | #1
Hey Brice,

That's indeed much better this way ;) You still have two small guix lint
warnings to fix:

gnu/packages/linux.scm:979:17: ddcci-driver-linux@0.3.3: sentences in description should be followed by two spaces; possible infractions at 143, 253
gnu/packages/linux.scm:978:14: ddcci-driver-linux@0.3.3: no article allowed at the beginning of the synopsis

Otherwise this LGTM.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 989d55f8aa..ce448d9940 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -968,6 +968,52 @@  and should be used with caution, especially on untested models.")
 between the CDemu userspace daemon and linux kernel.")
     (license license:gpl2+)))
 
+(define-public ddcci-driver-linux
+  (package
+    (name "ddcci-driver-linux")
+    (version "0.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux.git")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0vkkja3ykjil783zjpwp0vz7jy2fp9ccazzi3afd4fjk8gldin7f"))))
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f                               ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'build
+           (lambda args
+             (for-each
+              (lambda (module)
+                (with-directory-excursion module
+                  (apply (assoc-ref %standard-phases 'build) args)))
+              '("ddcci" "ddcci-backlight"))
+             #t))
+         (replace 'install
+           (lambda args
+             (for-each
+              (lambda (module)
+                (with-directory-excursion module
+                  (apply (assoc-ref %standard-phases 'install) args)))
+              '("ddcci" "ddcci-backlight"))
+             #t)))))
+    (home-page "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux")
+    (synopsis "A pair of Linux kernel drivers for DDC/CI monitors")
+    (description "This package provide two Linux kernel drivers, ddcci and
+ddcci-backlight, that allow the control of DDC/CI monitors through the sysfs
+interface. The ddcci module create a character device for each DDC/CI monitors
+in @file{/dev/bus/ddcci/[I²C busnumber]}. While the ddcci-backlight module
+allow the control of the backlight level or luminance property when supported
+under @file{/sys/class/backlight/}.")
+    (license license:gpl2+)))
+
 
 ;;;
 ;;; Pluggable authentication modules (PAM).