diff mbox series

[bug#37825] gnu: bitcoin-abc: Update to 0.20.4.

Message ID 20191019184837.21457-1-glv@posteo.net
State Accepted
Headers show
Series [bug#37825] gnu: bitcoin-abc: Update to 0.20.4. | expand

Commit Message

Guillaume Le Vaillant Oct. 19, 2019, 6:48 p.m. UTC
* gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
  [source]: Fix uri.
  [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
  [arguments]: Add 'fix-tests' phase.
---
 gnu/packages/finance.scm | 26 +++++++++++++++++++++++---
 1 file changed, 23 insertions(+), 3 deletions(-)

Comments

Marius Bakke Oct. 31, 2019, 11:23 p.m. UTC | #1
Guillaume Le Vaillant <glv@posteo.net> writes:

> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
>   [source]: Fix uri.
>   [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
>   [arguments]: Add 'fix-tests' phase.

[...]

> +    (arguments
> +     (substitute-keyword-arguments (package-arguments bitcoin-core)
> +       ((#:phases phases)
> +        `(modify-phases ,phases
> +           (add-after 'unpack 'fix-tests
> +             ;; Disable 'check-devtools' test which tries to run a
> +             ;; python script that doesn't exist.
> +             (lambda _
> +               (substitute* "Makefile.in"
> +                 (("^check-local: check-devtools")
> +                  "check-local:"))
> +               #t))))))

Do you know why this script is not distributed?  Should we provide it,
or was it a packaging mistake upstream?

In any case I pushed this patch in
28d46d9d4317180b348ad5baeddad8ef25ed430a.  Thank you!
Guillaume Le Vaillant Nov. 1, 2019, 10:18 a.m. UTC | #2
Marius Bakke skribis:

> Guillaume Le Vaillant <glv@posteo.net> writes:
>
>> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
>>   [source]: Fix uri.
>>   [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
>>   [arguments]: Add 'fix-tests' phase.
>
> [...]
>
>> +    (arguments
>> +     (substitute-keyword-arguments (package-arguments bitcoin-core)
>> +       ((#:phases phases)
>> +        `(modify-phases ,phases
>> +           (add-after 'unpack 'fix-tests
>> +             ;; Disable 'check-devtools' test which tries to run a
>> +             ;; python script that doesn't exist.
>> +             (lambda _
>> +               (substitute* "Makefile.in"
>> +                 (("^check-local: check-devtools")
>> +                  "check-local:"))
>> +               #t))))))
>
> Do you know why this script is not distributed?  Should we provide it,
> or was it a packaging mistake upstream?
>
> In any case I pushed this patch in
> 28d46d9d4317180b348ad5baeddad8ef25ed430a.  Thank you!

I'm not sure if it's a packaging mistake or a makefile mistake (if these
tests are not supposed to be run on a release version). They are tests
to check that some development tools work correctly (e.g. tools to
generate a header file which is included in the release tarball, to
update the copyright years in the headers, etc).
Marius Bakke Nov. 3, 2019, 5:11 p.m. UTC | #3
Guillaume Le Vaillant <glv@posteo.net> writes:

> Marius Bakke skribis:
>
>> Guillaume Le Vaillant <glv@posteo.net> writes:
>>
>>> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
>>>   [source]: Fix uri.
>>>   [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
>>>   [arguments]: Add 'fix-tests' phase.
>>
>> [...]
>>
>>> +    (arguments
>>> +     (substitute-keyword-arguments (package-arguments bitcoin-core)
>>> +       ((#:phases phases)
>>> +        `(modify-phases ,phases
>>> +           (add-after 'unpack 'fix-tests
>>> +             ;; Disable 'check-devtools' test which tries to run a
>>> +             ;; python script that doesn't exist.
>>> +             (lambda _
>>> +               (substitute* "Makefile.in"
>>> +                 (("^check-local: check-devtools")
>>> +                  "check-local:"))
>>> +               #t))))))
>>
>> Do you know why this script is not distributed?  Should we provide it,
>> or was it a packaging mistake upstream?
>>
>> In any case I pushed this patch in
>> 28d46d9d4317180b348ad5baeddad8ef25ed430a.  Thank you!
>
> I'm not sure if it's a packaging mistake or a makefile mistake (if these
> tests are not supposed to be run on a release version). They are tests
> to check that some development tools work correctly (e.g. tools to
> generate a header file which is included in the release tarball, to
> update the copyright years in the headers, etc).

I see, thanks for the explanation.  Perhaps we are simply using the
wrong Makefile target?  By default gnu-build-system runs 'make check' in
the 'check' phase: some packages use 'make test' or 'make ci' instead.

Something to look out for in the next version.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 960e3adeb3..0ab6489aeb 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1133,15 +1133,35 @@  Trezor wallet.")
   (package
     (inherit bitcoin-core)
     (name "bitcoin-abc")
-    (version "0.19.8")
+    (version "0.20.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.bitcoinabc.org/"
-                                  version "/linux/src/bitcoin-abc-"
+                                  version "/src/bitcoin-abc-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+                "0fld54z3l7z7k5n35rrjichjnx37j9xp0rv8i69m3x4qfj1xk2np"))))
+    (inputs
+     `(("bdb" ,bdb-5.3)
+       ("boost" ,boost)
+       ("libevent" ,libevent)
+       ("miniupnpc" ,miniupnpc)
+       ("openssl" ,openssl)
+       ("protobuf" ,protobuf)
+       ("qtbase" ,qtbase)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments bitcoin-core)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'fix-tests
+             ;; Disable 'check-devtools' test which tries to run a
+             ;; python script that doesn't exist.
+             (lambda _
+               (substitute* "Makefile.in"
+                 (("^check-local: check-devtools")
+                  "check-local:"))
+               #t))))))
     (home-page "https://www.bitcoinabc.org/")
     (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
     (description