diff mbox series

[bug#37788] gnu: Add minisign.

Message ID 20191017080954.rxj4m7dmelakx7zv@rafflesia
State Accepted
Headers show
Series [bug#37788] gnu: Add minisign. | expand

Commit Message

Tanguy LE CARROUR Oct. 17, 2019, 8:09 a.m. UTC
Remove new blank line at EOF.
From 467e7d9566cc655c4ea226769b76c8d803ecb4d4 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 17 Oct 2019 09:57:28 +0200
Subject: [PATCH] gnu: Add minisign.

* gnu/packages/crypto.scm (minisign): New public variable.
---
 gnu/packages/crypto.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Mathieu Othacehe Oct. 17, 2019, 3:32 p.m. UTC | #1
Hello Tanguy,

> Remove new blank line at EOF.

Please pass --subject-prefix="PATCH v2" to git format-patch so that it
is easier to identify patch revisions.

> +     ; No test suite

You can put it on the same line as the one below.

> +     `(#:tests? #f))

You also did forget to add the Copyright on top.

Otherwise seems fine :). I fixed the points above and pushed it.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9592d18011..9ab15a6395 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -974,3 +974,36 @@  pre-shared keys out of band.  It is designed to handle large amounts of data
 quickly by using all your CPU cores and hardware acceleration.")
     (home-page "https://github.com/vstakhov/hpenc")
     (license license:bsd-3)))
+
+(define-public minisign
+  (package
+    (name "minisign")
+    (version "0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/jedisct1/minisign/releases/download/"
+                       version "/minisign-" version ".tar.gz"))
+       (sha256
+        (base32
+         "10hhgwxf9rcdlr00shrkcyxndrc22dh5lj8k5z27xg3nc0jba3hk"))))
+    (build-system cmake-build-system)
+    (arguments
+     ; No test suite
+     `(#:tests? #f))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libsodium" ,libsodium)))
+    (home-page "https://jedisct1.github.io/minisign")
+    (synopsis "Tool to sign files and verify signatures")
+    (description
+     "Minisign is a dead simple tool to sign files and verify signatures.  It is
+portable, lightweight, and uses the highly secure Ed25519 public-key signature
+system.  Signature written by minisign can be verified using OpenBSD's
+signify tool: public key files and signature files are compatible.  However,
+minisign uses a slightly different format to store secret keys.  Minisign
+signatures include trusted comments in addition to untrusted comments.
+Trusted comments are signed, thus verified, before being displayed.")
+    (license license:isc)))