diff mbox series

[bug#37598,3/4] gnu: Add python-whichcraft.

Message ID 20191015074059.dxk6koux65jdaaqi@rafflesia
State Accepted
Headers show
Series None | expand

Commit Message

Tanguy LE CARROUR Oct. 15, 2019, 7:40 a.m. UTC
From 7e6bea798c400db245ae77c12b667cd3771dfb45 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 3 Oct 2019 09:17:05 +0200
Subject: [PATCH 3/4] gnu: Add python-whichcraft.

* gnu/packages/python-xyz.scm (python-whichcraft): New public variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0852877eb2..1a175295e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9127,6 +9127,29 @@  server with very acceptable performance.")
 (define-public python2-waitress
   (package-with-python2 python-waitress))
 
+(define-public python-whichcraft
+  (package
+    (name "python-whichcraft")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "whichcraft" version))
+       (sha256
+        (base32
+         "11yfkzyplizdgndy34vyd5qlmr1n5mxis3a3svxmx8fnccdvknxc"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page
+     "https://github.com/pydanny/whichcraft")
+    (synopsis "Cross-platform cross-python shutil.which functionality")
+    (description
+     "A shim of the shutil.which function that's designed to work
+across multiple versions of Python. The code for Python 2.x is based on
+Python 3 code that I extracted from source.")
+    (license license:bsd-3)))
+
 (define-public python-pyquery
   (package
     (name "python-pyquery")