diff mbox series

[bug#37598,2/4] gnu: Add python-poyo.

Message ID 20191015073824.q6cn7vn7qjdjxjvm@rafflesia
State Accepted
Headers show
Series None | expand

Commit Message

Tanguy LE CARROUR Oct. 15, 2019, 7:38 a.m. UTC
From a08b69b276c31b42b13d86732c93abc6984b6048 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 3 Oct 2019 09:13:59 +0200
Subject: [PATCH 2/4] gnu: Add python-poyo.

* gnu/packages/python-xyz.scm (python-poyo): New public variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 74898d1a87..0852877eb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1572,6 +1572,27 @@  existing ones.")
                    ;; Tests don't work with python2.
                    #:tests? #f)))))
 
+(define-public python-poyo
+  (package
+    (name "python-poyo")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "poyo" version))
+       (sha256
+        (base32
+         "1pflivs6j22frz0v3dqxnvc8yb8fb52g11lqr88z0i8cg2m5csg2"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/hackebrot/poyo")
+    (synopsis "Lightweight YAML Parser for Python")
+    (description
+     "A lightweight YAML Parser for Python. It supports only a chosen subset
+of the YAML format that is required to parse cookiecutter user configuration
+files. It does not have support for serializing into YAML and is not compatible
+with JSON.")
+    (license license:expat)))
+
 (define-public scons
   (package
     (name "scons")