diff mbox series

[bug#37704,4/9] gnu: Add python-memcached.

Message ID 20191014151744.46z6sqxn2df7g3ho@rafflesia
State Accepted
Headers show
Series None | expand

Commit Message

Tanguy LE CARROUR Oct. 14, 2019, 3:17 p.m. UTC
From 96dd29f12b93552a6aeacce1159bbf784b216fc7 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 09:51:17 +0200
Subject: [PATCH 4/9] gnu: Add python-memcached.

* gnu/packages/python-xyz.scm (python-memcached): New public variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d014b5e64..dcfd9d4221 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10562,6 +10562,29 @@  implementation as been adapted, improved and fixed from Molten.")
 running in.")
     (license license:isc)))
 
+(define-public python-memcached
+  (package
+    (name "python-memcached")
+    (version "1.59")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-memcached" version))
+       (sha256
+        (base32
+         "0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))))
+    (build-system python-build-system)
+    (propagated-inputs `(("python-six" ,python-six)))
+    (home-page
+     "https://github.com/linsomniac/python-memcached")
+    (synopsis "Pure python memcached client")
+    (description
+     "This software is a 100% Python interface to the memcached memory cache
+daemon. It is the client side software which allows storing values in one or
+more, possibly remote, memcached servers. Search google for memcached for more
+information.")
+    (license license:psfl)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")