diff mbox series

[bug#37704,3/9] gnu: Add python-shellingham.

Message ID 20191014151709.makdfhxpajytstyz@rafflesia
State Accepted
Headers show
Series None | expand

Commit Message

Tanguy LE CARROUR Oct. 14, 2019, 3:17 p.m. UTC
From 847a0e9e8b64badb10d1f6bb236f6e9300ace3ac Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 09:39:17 +0200
Subject: [PATCH 3/9] gnu: Add python-shellingham.

* gnu/packages/python-xyz.scm (python-shellingham): New public variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a83b91574e..1d014b5e64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10542,6 +10542,26 @@  create new TOML documents from scratch using the provided helpers.  Part of the
 implementation as been adapted, improved and fixed from Molten.")
     (license license:expat)))
 
+(define-public python-shellingham
+  (package
+    (name "python-shellingham")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shellingham" version))
+       (sha256
+        (base32
+         "1q7kws7w4x2hji3g7y0ni9ddk4sd676ylrb3db54gbpys6xj6nwq"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sarugaku/shellingham")
+    (synopsis "Tool to Detect Surrounding Shell")
+    (description
+     "Shellingham detects what shell the current Python executable is
+running in.")
+    (license license:isc)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")