diff mbox series

[bug#37618,v2] gnu: Add aha.

Message ID 20191004132157.10870-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#37618,v2] gnu: Add aha. | expand

Commit Message

Wiktor Żelazny Oct. 4, 2019, 1:21 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/textutils.scm (aha): new variable.
---
I fixed the issues pointed out by Tobias [bug#37603].
 gnu/packages/textutils.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Maja Kądziołka Feb. 22, 2020, 9:23 p.m. UTC | #1
On Fri, Oct 04, 2019 at 03:21:57PM +0200, Wiktor Żelazny wrote:
> From: Wiktor Żelazny <wzelazny@vurv.cz>
> 
> * gnu/packages/textutils.scm (aha): new variable.

Thanks! I fixed the synopsis and description up a bit:

(synopsis "Converts terminal escape sequences to HTML")
(description "@command{aha} (Ansi Html Adapter) converts ANSI escape sequences
of a Unix terminal to HTML code.")

Apart from that, LGTM, so pushed to master.

Sorry for the quite substantial delay,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 79cf172179..678c1292f5 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
+;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1011,3 +1012,30 @@  instance one can add new syntax elements to markdown, etc.
 
 This package provides Python bindings.")
     (license license:bsd-3)))
+
+(define-public aha
+  (package
+    (name "aha")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/theZiz/aha")
+              (commit version)))
+       (sha256
+        (base32
+         "0byml4rmpiaalwx69jcixl3yvpvwmwiss1jzgsqwshilb2p4qnmz"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases (delete 'configure))
+       #:make-flags (list "CC=gcc"
+                          (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:tests? #f)) ; no check target
+    (home-page "https://github.com/theZiz/aha")
+    (synopsis "Ansi HTML Adapter")
+    (description "@code{aha} converts ANSI escape sequences of a Unix terminal
+to HTML code.")
+    (license (list license:lgpl2.0+ license:mpl1.1))))