diff mbox series

[bug#37617,5/6] gnu: Add python-pyphen.

Message ID 20191004110824.16081-5-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#37617,1/6] gnu: Add python-pytest-isort. | expand

Commit Message

Hartmut Goebel Oct. 4, 2019, 11:08 a.m. UTC
* gnu/packages/python-xyz.scm (python-pyphen): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abcd7e7408..c7ffecabbf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16509,3 +16509,22 @@  SVG parser, trying to follow the SVG 1.1 recommendation from the W3C.  Once
 parsed, the result is drawn to a Cairo surface that can be exported to
 qvarious formats: PDF, PostScript, PNG and even SVG.")
     (license license:lgpl3+)))
+
+(define-public python-pyphen
+  (package
+    (name "python-pyphen")
+    (version "0.9.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Pyphen" version))
+       (sha256
+        (base32 "08c9y69ry9d6m4zalhnalg86lsp9v2j5n1ziw5vxfmiihx83lqrv"))))
+    (build-system python-build-system)
+    ;; TODO: Use the Guix system hyphenation packages hyphen-* rather than the
+    ;; embedded set provided by upstream - like Debian does.
+    (home-page "https://github.com/Kozea/Pyphen")
+    (synopsis "Pure Python module to hyphenate text")
+    (description "Pyphen is a pure Python module to hyphenate text using
+existing Hunspell hyphenation dictionaries.")
+    (license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))