diff mbox series

[bug#37614,1/1] gnu: Fix and upgrade python-pastel.

Message ID 20191004075556.pg3vwfaklaj27vac@rafflesia
State Accepted
Headers show
Series gnu: Fix and upgrade python-pastel. | expand

Commit Message

Tanguy LE CARROUR Oct. 4, 2019, 7:55 a.m. UTC
From 1d97f3224f01721567120a5568c0416bfbe0dd35 Mon Sep 17 00:00:00 2001
From: "tlecarrour@easter-eggs.com" <tanguy@bioneland.org>
Date: Fri, 4 Oct 2019 09:48:40 +0200
Subject: [PATCH] gnu: Fix and upgrade python-pastel.

---
 gnu/packages/graphics.scm | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

Comments

Efraim Flashner Oct. 6, 2019, 8:49 a.m. UTC | #1
Patch pushed. I expanded the commit message and changed the spacing on
the custom 'check phase.
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6d6c8d1e1c..8a3c39373b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -913,28 +914,27 @@  rendering SVG graphics.")
 (define-public python-pastel
   (package
     (name "python-pastel")
-    (version "0.1.0")
+    (version "0.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pastel" version))
        (sha256
         (base32
-         "1hqbm934n5yjwn31aq8h7shrr0rcy326wrqfc856vyn0gr0sy21i"))))
+         "1qxcrcl8pzh66l8s6hym153mijdhwna0afcsmgca0bj4n80ijfxz"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases
+                    %standard-phases
+                  (replace
+                      'check
+                    (lambda _ (invoke "pytest" "pastel" "tests/"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page "https://github.com/sdispater/pastel")
     (synopsis "Library to colorize strings in your terminal")
     (description "Pastel is a simple library to help you colorize strings in
-your terminal.  It comes bundled with predefined styles:
-@enumerate
-@item info: green
-@item comment: yellow
-@item question: black on cyan
-@item error: white on red
-@end enumerate
-")
+your terminal.")
     (license license:expat)))
 
 (define-public python2-pastel